summaryrefslogtreecommitdiff
path: root/dev-python/python-senlinclient/python-senlinclient-2.1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-senlinclient/python-senlinclient-2.1.1.ebuild')
-rw-r--r--dev-python/python-senlinclient/python-senlinclient-2.1.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/python-senlinclient/python-senlinclient-2.1.1.ebuild b/dev-python/python-senlinclient/python-senlinclient-2.1.1.ebuild
new file mode 100644
index 000000000000..6c6e07edc485
--- /dev/null
+++ b/dev-python/python-senlinclient/python-senlinclient-2.1.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_6 python3_7 python3_8 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Senlin API"
+HOMEPAGE="https://github.com/openstack/python-senlinclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
+
+DEPEND=">=dev-python/pbr-2.1.1[${PYTHON_USEDEP}]"
+RDEPEND=">=dev-python/pbr-2.1.1[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.2[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/openstacksdk-0.24.0[${PYTHON_USEDEP}]
+ >=dev-python/osc-lib-1.11.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-2.18.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-serialization-2.19.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/python-heatclient-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.13.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]"