summaryrefslogtreecommitdiff
path: root/dev-python/python-spidermonkey
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-spidermonkey')
-rw-r--r--dev-python/python-spidermonkey/Manifest4
-rw-r--r--dev-python/python-spidermonkey/files/python-spidermonkey-0.0.10-tests.patch12
-rw-r--r--dev-python/python-spidermonkey/metadata.xml12
-rw-r--r--dev-python/python-spidermonkey/python-spidermonkey-0.0.10.ebuild28
4 files changed, 0 insertions, 56 deletions
diff --git a/dev-python/python-spidermonkey/Manifest b/dev-python/python-spidermonkey/Manifest
deleted file mode 100644
index 6c52768fc19c..000000000000
--- a/dev-python/python-spidermonkey/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-AUX python-spidermonkey-0.0.10-tests.patch 367 BLAKE2B fbb66a1303b9a02adcf2a6f3ac8d2b1e095b50c0ea900cc3e2aba37105551b3d3d557ab3415149c5cdc1dae1c855344db85d079e869e38cd8cf8165c3afcc160 SHA512 621375af9ee114ec01d1176e1ccb578a84b81d524a8d762d76998e38906167ba7eb47561ec60aa3f5fb31b5f78668df2be937e79bcb4a2a23e11dbdfe042f0c1
-DIST python-spidermonkey-0.0.10.tar.gz 787526 BLAKE2B 95a49c3735ee71c16a76b2e768a17454549625dee5c429456da1cc3f7bc3a1bc238c85c29d66eb02f64bc73b55193186d90f4a872f4e4b7ab0c550c0384fe5b9 SHA512 e3d45ba2e747f8f382e273962f8015be8e736cbd49246864d894d7db1d436c9e14c5e945f4bd3cf3a7aca8d4f60d0f57855704c5d2cac94630df26e67898f591
-EBUILD python-spidermonkey-0.0.10.ebuild 598 BLAKE2B c2dc4e9f73c75b0f556ced4cbd01589d2691950b57b98164779ed7b2d302fa166065c81cfdea2ccf2a7ec4c8e33f51e4d7c9f554d41ab690130944e88f3b3964 SHA512 535b59ee834362dda665dd3fb9c179b8055354bc9502ded06a273dc2a9f4b85651b1d2ae3ebbecfdd487d5128604999cfe5607d1553d129cd87acc9655b2f85a
-MISC metadata.xml 383 BLAKE2B 6915312d399c4d76172c43c41e0f048f1e7e86b4d7d52ac817599350b9925db2f44189f9a5cdc9cd93c441c2818bcd35cfc467b98bd2da4da6805a350414ec80 SHA512 6e797e5902ba63378abdea1901aed16645d95a664909a8fb86e30ecf6e63a606731a268a6b3a541b969e40c74e5c86bdc93a444529341fbc010ea950687880df
diff --git a/dev-python/python-spidermonkey/files/python-spidermonkey-0.0.10-tests.patch b/dev-python/python-spidermonkey/files/python-spidermonkey-0.0.10-tests.patch
deleted file mode 100644
index fca5fdd3d79c..000000000000
--- a/dev-python/python-spidermonkey/files/python-spidermonkey-0.0.10-tests.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/tests/test-syntax-error.py b/tests/test-syntax-error.py
-index ab14deb..78fc0ed 100644
---- a/tests/test-syntax-error.py
-+++ b/tests/test-syntax-error.py
-@@ -9,7 +9,3 @@ import traceback
- def test_syntax_error(cx):
- t.raises(t.JSError, cx.execute, "function(asdf;")
-
--@t.cx()
--def test_invalid_octal(cx):
-- t.raises(t.JSError, cx.execute, "09;")
--
diff --git a/dev-python/python-spidermonkey/metadata.xml b/dev-python/python-spidermonkey/metadata.xml
deleted file mode 100644
index e92ae67745a0..000000000000
--- a/dev-python/python-spidermonkey/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
- <longdescription>
- JavaScript / Python bridge
- </longdescription>
- <upstream>
- <remote-id type="pypi">python-spidermonkey</remote-id>
- <remote-id type="github">davisp/python-spidermonkey</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/python-spidermonkey/python-spidermonkey-0.0.10.ebuild b/dev-python/python-spidermonkey/python-spidermonkey-0.0.10.ebuild
deleted file mode 100644
index 0d4c1265b247..000000000000
--- a/dev-python/python-spidermonkey/python-spidermonkey-0.0.10.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=(python2_7)
-inherit distutils-r1
-
-DESCRIPTION="JavaScript / Python bridge"
-HOMEPAGE="https://github.com/davisp/python-spidermonkey"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-
-CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${CDEPEND}
- dev-libs/nspr
- >=dev-python/nose-0.10.0[${PYTHON_USEDEP}]"
-RDEPEND="${CDEPEND}"
-
-PATCHES=("${FILESDIR}"/${P}-tests.patch)
-
-python_test() {
- esetup.py test
-}