summaryrefslogtreecommitdiff
path: root/dev-python/python3-saml/python3-saml-1.15.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python3-saml/python3-saml-1.15.0.ebuild')
-rw-r--r--dev-python/python3-saml/python3-saml-1.15.0.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/python3-saml/python3-saml-1.15.0.ebuild b/dev-python/python3-saml/python3-saml-1.15.0.ebuild
deleted file mode 100644
index 48d771b7a68b..000000000000
--- a/dev-python/python3-saml/python3-saml-1.15.0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 2020-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="OneLogin's SAML Python Toolkit"
-HOMEPAGE="
- https://github.com/SAML-Toolkits/python3-saml/
- https://pypi.org/project/python3-saml/
-"
-SRC_URI="
- https://github.com/SAML-Toolkits/python3-saml/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-
-RDEPEND="
- >=dev-python/isodate-0.6.1[${PYTHON_USEDEP}]
- >=dev-python/lxml-4.9.0[${PYTHON_USEDEP}]
- >=dev-python/xmlsec-1.3.9[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/freezegun[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests unittest
-
-python_test() {
- # The tests are horribly fragile to paths.
- local -x PYTHONPATH=src
- eunittest -p '*_test.py'
-}