summaryrefslogtreecommitdiff
path: root/dev-python/pytidylib/pytidylib-0.2.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytidylib/pytidylib-0.2.4.ebuild')
-rw-r--r--dev-python/pytidylib/pytidylib-0.2.4.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/pytidylib/pytidylib-0.2.4.ebuild b/dev-python/pytidylib/pytidylib-0.2.4.ebuild
new file mode 100644
index 000000000000..af2a120838e2
--- /dev/null
+++ b/dev-python/pytidylib/pytidylib-0.2.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for HTML Tidy (tidylib)"
+HOMEPAGE="http://countergram.com/open-source/pytidylib https://github.com/countergram/pytidylib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd"
+IUSE="test"
+
+RDEPEND="app-text/htmltidy"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest )"
+
+python_test() {
+ py.test -vv || die
+}