summaryrefslogtreecommitdiff
path: root/dev-python/pytidylib/pytidylib-0.3.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytidylib/pytidylib-0.3.2.ebuild')
-rw-r--r--dev-python/pytidylib/pytidylib-0.3.2.ebuild19
1 files changed, 7 insertions, 12 deletions
diff --git a/dev-python/pytidylib/pytidylib-0.3.2.ebuild b/dev-python/pytidylib/pytidylib-0.3.2.ebuild
index cc0660c92ba6..f22aa524309c 100644
--- a/dev-python/pytidylib/pytidylib-0.3.2.ebuild
+++ b/dev-python/pytidylib/pytidylib-0.3.2.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy pypy3 )
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
inherit distutils-r1
@@ -13,15 +14,9 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
SLOT="0"
LICENSE="MIT"
-KEYWORDS="~alpha amd64 ~arm arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
+KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86"
-RDEPEND="app-text/htmltidy
- dev-python/setuptools"
-DEPEND="${RDEPEND}
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+RDEPEND="app-text/htmltidy"
+DEPEND=${RDEPEND}
-python_test() {
- pytest -vv || die
-}
+distutils_enable_tests pytest