summaryrefslogtreecommitdiff
path: root/dev-python/pyudev
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyudev')
-rw-r--r--dev-python/pyudev/Manifest5
-rw-r--r--dev-python/pyudev/files/pyudev-0.19.0-skip-non-deterministic-test.patch78
-rw-r--r--dev-python/pyudev/pyudev-0.21.0.ebuild55
-rw-r--r--dev-python/pyudev/pyudev-0.22.0.ebuild2
4 files changed, 2 insertions, 138 deletions
diff --git a/dev-python/pyudev/Manifest b/dev-python/pyudev/Manifest
index b2a3d5a60579..dc1ca27a9a4d 100644
--- a/dev-python/pyudev/Manifest
+++ b/dev-python/pyudev/Manifest
@@ -1,6 +1,3 @@
-AUX pyudev-0.19.0-skip-non-deterministic-test.patch 3497 BLAKE2B bfbbd7bcb401d807531321cb15c71a52b7b039a3c7ad5cd06e9c919e6b6ef232fb16419f0480ce89e316770db523bcd3e02edc7c4f259803f4a3c93e2b0edbbe SHA512 23c305242e4df0bd0d4cde458ca1ee129bef36f98f5b7c3b341c4866b7f21a51ffaf07aa56901aeb67ccb59a4ed6548d4799ae2c519e359b627b29e722119a4d
-DIST pyudev-0.21.0.tar.gz 89469 BLAKE2B 3bf9ac46442c5948d131932c7b62a59ef979755f2d55bcd0165fc1b69b865268051fdeab7605c8a1cb0694ce0f4b88f31a1e6a1893900a7300ddf6439734712e SHA512 ba5b6156768b65b9655d809b14378b01173643781b9c4017271e880cdfed442c44ac49eb26c970e4275b820e01678e3001870591fccf88dc713ec941e2b85d11
DIST pyudev-0.22.0.tar.gz 85077 BLAKE2B 66c78aa4d3bea5ceae3660a93e5bd1733629bb5228d67d8e647abb8c237a2786c1061b07e034be5467f5bcab58d95ba30f91d74bdc54cd8253dff69be3ad4a80 SHA512 a09ed479a54a1772a6af68cb975fef792068c2de3655e20223905bc3f574fd32bd3dbe6b97062eee3ab5f08a8b041ad3ea86dfb68c839ea44e29d65ec1686670
-EBUILD pyudev-0.21.0.ebuild 1351 BLAKE2B eeb674f652db9561eb5f695aeedcb95f05fabb191a68e34e1baa5569020efef0d32fa3455bf8d8b0079ec4e71473d4c85270e0802e130250808a3fa07510defe SHA512 e533e4aa0e2fa91acf7bf3511cce433cf1f9af6b23ac9328d8ff51e76b75d4c1f433f498432f374a2c370cfb8dfe7d77fdbd863d04f196cadbe93f6bfd61c496
-EBUILD pyudev-0.22.0.ebuild 1245 BLAKE2B 161caabb31e58774aba17df1d6f1f914f147c182856077b5ca9ce9af985935202bc55d51db144decd18398711c5df0b4e12149199a3af2ca3efc2c89f9847296 SHA512 81da5fdc4e5fb229c0d728a0b0451ffe670435c072395d97106eb30d1309735b5428c2d56945fe6122d39eae4ca632e937c13769f9b8ee7a88270e574b5650dd
+EBUILD pyudev-0.22.0.ebuild 1242 BLAKE2B ddc4bb4be2905aaa36fc24747d1a22b27ff18ab04b2ceea2caaf8ef1670097b4d0c0a872201dc2702d53308ed9e1fb468707ec11e32954caff7a890a0fbee488 SHA512 b56285f8105f646afa6df35707d3aadb6efa483bf87de97a3b6227b8404d0ca8b26174cbc45b96b929a455a9e2eeb42267086d4dd3d9f1627a63f484da871827
MISC metadata.xml 593 BLAKE2B bb5efdb90e8b189f55f12df33d7bc69233a448d010c62b512cdbea78c58a625d0e876b48cdac3342e3588e3bb1f3998d9400e927fecf7bb86ad01da113c97758 SHA512 dd6e479a44e54d4e3b2a4b7a3ceedf04fd45152d9667227b4f7bf0c585052e1adedda44084c6251749714ba91bfb8ae2969c158bb3412edf1230f5b8d1d1c768
diff --git a/dev-python/pyudev/files/pyudev-0.19.0-skip-non-deterministic-test.patch b/dev-python/pyudev/files/pyudev-0.19.0-skip-non-deterministic-test.patch
deleted file mode 100644
index 268d2bdf1b4c..000000000000
--- a/dev-python/pyudev/files/pyudev-0.19.0-skip-non-deterministic-test.patch
+++ /dev/null
@@ -1,78 +0,0 @@
-diff --git a/tests/_device_tests/_attributes_tests.py b/tests/_device_tests/_attributes_tests.py
-index 54d8ae6..84e26c3 100644
---- a/tests/_device_tests/_attributes_tests.py
-+++ b/tests/_device_tests/_attributes_tests.py
-@@ -88,6 +88,7 @@ def test_non_iterable(self, a_device):
- with pytest.raises(TypeError):
- a_device.attributes['key']
-
-+ @pytest.mark.skipif(True, reason='Non-deterministic')
- @given(_CONTEXT_STRATEGY, strategies.sampled_from(_DEVICE_DATA))
- @settings(max_examples=5)
- def test_asstring(self, a_context, device_datum):
-@@ -99,6 +100,7 @@ def test_asstring(self, a_context, device_datum):
- assert is_unicode_string(device.attributes.asstring(key))
- assert device.attributes.asstring(key) == value
-
-+ @pytest.mark.skipif(True, reason='Non-deterministic')
- @given(_CONTEXT_STRATEGY, strategies.sampled_from(_DEVICE_DATA))
- @settings(max_examples=5)
- def test_asint(self, a_context, device_datum):
-@@ -115,6 +117,7 @@ def test_asint(self, a_context, device_datum):
- else:
- assert device.attributes.asint(key) == value
-
-+ @pytest.mark.skipif(True, reason='Non-deterministic')
- @given(_CONTEXT_STRATEGY, strategies.sampled_from(_DEVICE_DATA))
- @settings(max_examples=5)
- def test_asbool(self, a_context, device_datum):
-diff --git a/tests/_device_tests/_device_tests.py b/tests/_device_tests/_device_tests.py
-index 92a767d..175c611 100644
---- a/tests/_device_tests/_device_tests.py
-+++ b/tests/_device_tests/_device_tests.py
-@@ -378,6 +378,7 @@ def test_getitem_nonexisting(self, a_device):
- a_device['a non-existing property']
- assert str(excinfo.value) == repr('a non-existing property')
-
-+ @pytest.mark.skipif(True, reason='Non-deterministic')
- @given(_CONTEXT_STRATEGY, strategies.sampled_from(_DEVICE_DATA))
- @settings(max_examples=5)
- def test_asint(self, a_context, device_datum):
-@@ -391,6 +392,7 @@ def test_asint(self, a_context, device_datum):
- else:
- assert device.asint(property) == value
-
-+ @pytest.mark.skipif(True, reason='Non-deterministic')
- @given(_CONTEXT_STRATEGY, strategies.sampled_from(_DEVICE_DATA))
- @settings(max_examples=5)
- def test_asbool(self, a_context, device_datum):
-diff --git a/tests/_device_tests/_devices_tests.py b/tests/_device_tests/_devices_tests.py
-index 8eb8069..b80e550 100644
---- a/tests/_device_tests/_devices_tests.py
-+++ b/tests/_device_tests/_devices_tests.py
-@@ -189,8 +189,8 @@ def test_from_device_file(self, a_context, device_datum):
-
- _device_data = [d for d in _DEVICE_DATA if list(d.device_links)]
- @pytest.mark.skipif(
-- len(_device_data) == 0,
-- reason='no device with a device node'
-+ True,
-+ reason='non deterministic'
- )
- @given(_CONTEXT_STRATEGY, strategies.sampled_from(_device_data))
- @settings(max_examples=5, min_satisfying_examples=1)
-diff --git a/tests/test_discover.py b/tests/test_discover.py
-index dd336d5..c410a64 100644
---- a/tests/test_discover.py
-+++ b/tests/test_discover.py
-@@ -155,8 +155,8 @@ def test_name(self, a_device):
-
- _devices = [d for d in _DEVICES if list(d.device_links)]
- @pytest.mark.skipif(
-- len(_devices) == 0,
-- reason="no device with device links"
-+ True,
-+ reason='Non-deterministic'
- )
- @given(strategies.sampled_from(_devices))
- @settings(max_examples=NUM_TESTS, min_satisfying_examples=1)
diff --git a/dev-python/pyudev/pyudev-0.21.0.ebuild b/dev-python/pyudev/pyudev-0.21.0.ebuild
deleted file mode 100644
index 684711ee05ca..000000000000
--- a/dev-python/pyudev/pyudev-0.21.0.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{3_6,3_7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python binding to libudev"
-HOMEPAGE="https://pyudev.readthedocs.io/en/latest/ https://github.com/pyudev/pyudev"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 arm ~arm64 ~mips x86"
-IUSE="qt5 test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/six[${PYTHON_USEDEP}]
- virtual/udev
- qt5? ( dev-python/PyQt5[${PYTHON_USEDEP}] )
-"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/docutils[${PYTHON_USEDEP}]
- dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
- )"
-
-DOCS=( CHANGES.rst README.rst )
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.19.0-skip-non-deterministic-test.patch"
-)
-
-python_prepare_all() {
- if use test; then
- ewarn "If your PORTAGE_TMPDIR is longer in length then '/var/tmp/',"
- ewarn "change it to /var/tmp to ensure tests will pass."
- fi
-
- # tests are known to pass then fail on alternate runs
- # tests: fix run_path
- sed -i -e "s|== \('/run/udev'\)|in (\1,'/dev/.udev')|g" \
- tests/test_core.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- py.test -v || die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/pyudev/pyudev-0.22.0.ebuild b/dev-python/pyudev/pyudev-0.22.0.ebuild
index 2fba5997b60f..a5698f776247 100644
--- a/dev-python/pyudev/pyudev-0.22.0.ebuild
+++ b/dev-python/pyudev/pyudev-0.22.0.ebuild
@@ -12,7 +12,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+KEYWORDS="amd64 arm ~arm64 ~mips x86"
IUSE="qt5"
RDEPEND="