summaryrefslogtreecommitdiff
path: root/dev-python/pyzbar/pyzbar-0.1.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyzbar/pyzbar-0.1.5.ebuild')
-rw-r--r--dev-python/pyzbar/pyzbar-0.1.5.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/pyzbar/pyzbar-0.1.5.ebuild b/dev-python/pyzbar/pyzbar-0.1.5.ebuild
deleted file mode 100644
index 402f0bd97dac..000000000000
--- a/dev-python/pyzbar/pyzbar-0.1.5.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-inherit distutils-r1
-
-DESCRIPTION="Read one-dimensional barcodes and QR codes from Python"
-HOMEPAGE="https://github.com/NaturalHistoryMuseum/pyzbar/"
-SRC_URI="https://github.com/NaturalHistoryMuseum/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND="
- dev-python/pillow[${PYTHON_USEDEP}]
- media-gfx/zbar
- virtual/python-enum34[${PYTHON_USEDEP}]
- virtual/python-pathlib[${PYTHON_USEDEP}]
-"
-
-DEPEND="
- ${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- virtual/python-unittest-mock[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- )
-"
-
-python_test() {
- "${EPYTHON}" -m unittest discover -v || die "Testing failed with ${EPYTHON}"
-}