summaryrefslogtreecommitdiff
path: root/dev-python/qtpy
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/qtpy')
-rw-r--r--dev-python/qtpy/Manifest5
-rw-r--r--dev-python/qtpy/metadata.xml49
-rw-r--r--dev-python/qtpy/qtpy-2.4.1-r2.ebuild245
-rw-r--r--dev-python/qtpy/qtpy-2.4.2.ebuild244
4 files changed, 543 insertions, 0 deletions
diff --git a/dev-python/qtpy/Manifest b/dev-python/qtpy/Manifest
new file mode 100644
index 000000000000..fc48f382d7cc
--- /dev/null
+++ b/dev-python/qtpy/Manifest
@@ -0,0 +1,5 @@
+DIST QtPy-2.4.1.tar.gz 65492 BLAKE2B 3816e3836c171f75fc1877984b533602c8929a791b09a1f53b14687eae7a1067e47fcae3a198d798417521a1a81829168d3af94178b28d8a3bd2c28e7d9f7865 SHA512 cb7c65cfec5aba9bdc4942b95108ac0300eac5ca8f0c984e8ea789b77fded3a1817f591d43bc45e9aa4feb3cb3da64c0d42ae67f12121a807cf7c247e7612e7d
+DIST qtpy-2.4.2.tar.gz 66849 BLAKE2B 1eb362e797950d6c1406fb02bb3047ca7f8fdecd2b75371ab34f39601c9bdebce33336e3809c0d35dca31673c88d1734721a6dfdfb65f2ce20729445c4a4ca27 SHA512 2f9a0e1a4839c8dca23b4364900a12c2bd00f518353785a41eb6bd62fdc469670457f18224e1150a5a216ff5d0c4e799c3a1711ff7703ea07fadd655538fa37a
+EBUILD qtpy-2.4.1-r2.ebuild 8786 BLAKE2B 69c4dba488aaf64a539153ad9ada4b0a031cfa1c5ac8ecd05e02ed24d5993002cef1263b431fbede82b60ecef780bc011b189e23ee9bbb94c235778bcb68eb54 SHA512 d8e57c946f51169da1c2c4d7df1d6977204838942038304492f8b3ac32781316001d475d6ec91a57015e1d62d631cd596b13e9bf52b8e19a4e80785d9bce0a50
+EBUILD qtpy-2.4.2.ebuild 8781 BLAKE2B cb0c5cad95c5601d33bcb0784d1671309e62f6cdbc66765201370ac28e145de513c28b5cb9b436263771abf44ed9fb07b214c9436846cdab3bfd00c501e7cd54 SHA512 4c1f89585b731945788f67c66d5789d417a8f14d2aba145ce341cfe648f460511e697b29f0070cbe376ca0cb5c07032dfee422dc44645d2f08754c8179016da3
+MISC metadata.xml 2851 BLAKE2B c812a6a64662012c91334e57799c620164146abde81c120efda3db051ee102495b56cdbf325dac1f668ea50f83b2e928677b88722abb584dc31260b5a75ab067 SHA512 d4d4d0308d23811bff6c1784d0afc54d8df9d96c9397f0f2e49e04eff647fc1697474c2bb69b623a14ac39017e1d1ec292065c413bca1e029e4af818e65ce2f3
diff --git a/dev-python/qtpy/metadata.xml b/dev-python/qtpy/metadata.xml
new file mode 100644
index 000000000000..6d647f05cf63
--- /dev/null
+++ b/dev-python/qtpy/metadata.xml
@@ -0,0 +1,49 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Gentoo Python Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>nowa@gentoo.org</email>
+ <name>Nowa Ammerlaan</name>
+ </maintainer>
+ <longdescription>
+ QtPy is a small abstraction layer that lets you write applications using a single API call to either PyQt or PySide.
+ It provides support for PyQt5, PyQt4, PySide2 and PySide using the Qt5 layout (where the QtGui module has been split into QtGui and QtWidgets).
+ Basically, you can write your code as if you were using PySide2 but import Qt modules from qtpy instead of PySide2 (or PyQt5)
+ </longdescription>
+ <use>
+ <flag name="pyqt5">Use <pkg>dev-python/pyqt5</pkg> as Qt for Python implementation</flag>
+ <flag name="pyqt6">Use <pkg>dev-python/pyqt6</pkg> as Qt for Python implementation</flag>
+ <flag name="pyside2">Use <pkg>dev-python/pyside2</pkg> as Qt for Python implementation</flag>
+ <flag name="pyside6">Use <pkg>dev-python/pyside6</pkg> as Qt for Python implementation</flag>
+ <flag name="designer">Pull in bindings for the QtDesigner module and enable the designer plugin</flag>
+ <flag name="gui">Pull in bindings for the QtGui module</flag>
+ <flag name="help">Pull in bindings for the QtHelp module</flag>
+ <flag name="multimedia">Pull in QtMultimedia and QtMultimediaWidgets modules</flag>
+ <flag name="network">Pull in bindings for the QtNetwork module</flag>
+ <flag name="opengl">Pull in bindings for the QtOpenGL module</flag>
+ <flag name="positioning">Pull in bindings for the QtPositioning module</flag>
+ <flag name="printsupport">Pull in bindings for the QtPrintSupport module</flag>
+ <flag name="qml">Build bindings for the QtQml</flag>
+ <flag name="quick">Build bindings for the QtQuick</flag>
+ <flag name="sensors">Pull in bindings for the QtSensors module</flag>
+ <flag name="serialport">Pull in bindings for the QtSerialPort module</flag>
+ <flag name="speech">Pull in bindings for the QtTextToSpeech module</flag>
+ <flag name="sql">Pull in bindings for the QtSql module</flag>
+ <flag name="svg">Pull in bindings for the QtSvg module</flag>
+ <flag name="testlib">Pull in bindings for the QtTest module</flag>
+ <flag name="webchannel">Pull in bindings for the QtWebChannel module</flag>
+ <flag name="webengine">Pull in QtWebEngine and QtWebEngineWidgets modules</flag>
+ <flag name="websockets">Pull in bindings for the QtWebSockets module</flag>
+ <flag name="widgets">Pull in bindings for the QtWidgets module</flag>
+ <flag name="xml">Pull in QtXml module</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">spyder-ide/qtpy</remote-id>
+ <remote-id type="pypi">QtPy</remote-id>
+ </upstream>
+ <stabilize-allarches/>
+</pkgmetadata>
diff --git a/dev-python/qtpy/qtpy-2.4.1-r2.ebuild b/dev-python/qtpy/qtpy-2.4.1-r2.ebuild
new file mode 100644
index 000000000000..23af9c33307c
--- /dev/null
+++ b/dev-python/qtpy/qtpy-2.4.1-r2.ebuild
@@ -0,0 +1,245 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=QtPy
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 virtualx pypi
+
+DESCRIPTION="Abstraction layer on top of PyQt and PySide with additional custom QWidgets"
+HOMEPAGE="
+ https://github.com/spyder-ide/qtpy/
+ https://pypi.org/project/QtPy/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ~loong ~ppc64 ~riscv x86"
+
+_IUSE_QT_MODULES="
+ designer +gui help multimedia +network opengl positioning
+ printsupport qml quick sensors serialport speech +sql svg testlib
+ webchannel webengine websockets +widgets +xml
+"
+IUSE="+pyqt5 +pyqt6 pyside2 pyside6 ${_IUSE_QT_MODULES}"
+unset _IUSE_QT_MODULES
+
+REQUIRED_USE="
+ || ( pyqt5 pyqt6 pyside2 pyside6 )
+ python_targets_python3_12? ( !pyside2 )
+ python_targets_python3_13? ( !pyside2 )
+"
+
+# These flags are currently *not* common to the PySide2/6 and PyQt5/6 ebuilds
+# Disable them for now, please check periodically if this is still up to date.
+# bluetooth? ( pyqt5/6 and pyside6 only )
+# dbus? ( pyqt5/6 and pyside6 only )
+#
+# 3d? ( pyside2/6 only )
+# charts? ( pyside2 only )
+# concurrent? ( pyside2 only )
+# datavis? ( pyside2 only )
+# scxml? ( pyside2/6 only )
+#
+# x11extras? ( pyside2 and pyqt5 only )
+# xmlpatterns? ( pyside2 and pyqt5 only )
+#
+# location? ( pyside2/6 and pyqt5 only)
+# nfc? ( pyqt6 and pyside6 only)
+# spatialaudio? ( pyqt6 and pyside6 only)
+# pdfium? ( pyqt6 and pyside6 only)
+
+# WARNING: the obvious solution of using || for PyQt5/pyside2 is not going
+# to work. The package only checks whether PyQt5/pyside2 is installed, it does
+# not verify whether they have the necessary modules (i.e. satisfy the USE dep).
+#
+# Webengine is a special case, because PyQt5 provides this in a separate package
+# while PySide2 ships it in the same package.
+#
+# declarative/qml/quick is a special case, because PyQt5 bundles the bindings
+# for qml and quick in one flag: declarative PySide2 does not.
+#
+# The PyQt5 ebuild currently enables xml support unconditionally, the flag is
+# added anyway with a (+) to make it future proof if the ebuild were to change
+# this behaviour in the future.
+#
+# The PySide2 ebuild currently enables opengl and serialport support
+# unconditionally, the flag is added anyway with a (+) to make it future proof
+# if the ebuild were to change this behaviour in the future.
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ pyqt5? (
+ dev-python/pyqt5[${PYTHON_USEDEP}]
+ dev-python/pyqt5[designer?,gui?,help?,multimedia?,network?,opengl?]
+ dev-python/pyqt5[positioning?,printsupport?,sensors?,serialport?,speech?,sql?,svg?]
+ dev-python/pyqt5[testlib?,webchannel?,websockets?,widgets?,xml(+)?]
+ qml? ( dev-python/pyqt5[declarative] )
+ quick? ( dev-python/pyqt5[declarative] )
+ webengine? ( dev-python/pyqtwebengine[${PYTHON_USEDEP}] )
+ )
+ pyqt6? (
+ dev-python/pyqt6[${PYTHON_USEDEP}]
+ dev-python/pyqt6[designer?,gui?,help?,multimedia?,network?,opengl?]
+ dev-python/pyqt6[positioning?,printsupport?,qml?,quick?,sensors?,serialport?,sql?]
+ dev-python/pyqt6[speech?,svg?,testlib?,webchannel?,websockets?,widgets?,xml?]
+ webengine? ( dev-python/pyqt6-webengine[${PYTHON_USEDEP},widgets?,quick?] )
+
+ )
+ pyside2? (
+ $(python_gen_cond_dep '
+ dev-python/pyside2[${PYTHON_USEDEP}]
+ dev-python/pyside2[designer?,gui?,help?,multimedia?,network?,opengl(+)?]
+ dev-python/pyside2[positioning?,printsupport?,qml?,quick?,sensors?,serialport(+)?]
+ dev-python/pyside2[speech?,sql?,svg?,testlib?,webchannel?,webengine?,websockets?]
+ dev-python/pyside2[widgets?,xml?]
+ ' python3_{10..11})
+ )
+ pyside6? (
+ dev-python/pyside6[${PYTHON_USEDEP}]
+ dev-python/pyside6[designer?,gui?,help?,multimedia?,network?,opengl?]
+ dev-python/pyside6[positioning?,printsupport?,qml?,quick?,sensors(-)?,serialport?]
+ dev-python/pyside6[speech(-)?,sql?,svg?,testlib?,webchannel?,webengine?,websockets?]
+ dev-python/pyside6[widgets?,xml?]
+ )
+"
+
+# The QtPy testsuite skips tests for bindings that are not installed, so here we
+# ensure that everything is available and all tests are run. Note that not
+# all flags are available in PyQt5/PySide2, so some tests are still skipped.
+BDEPEND="
+ test? (
+ dev-python/pytest-qt[${PYTHON_USEDEP}]
+ pyqt5? (
+ dev-python/pyqt5[${PYTHON_USEDEP}]
+ dev-python/pyqt5[bluetooth,dbus,declarative,designer,gui,help,location]
+ dev-python/pyqt5[multimedia,network,opengl,positioning,printsupport]
+ dev-python/pyqt5[sensors,serialport,speech(-),sql,svg,testlib,webchannel]
+ dev-python/pyqt5[websockets,widgets,x11extras,xml(+),xmlpatterns]
+ dev-python/pyqtwebengine[${PYTHON_USEDEP}]
+ dev-qt/qtsql:5[sqlite]
+ )
+ pyqt6? (
+ dev-python/pyqt6[${PYTHON_USEDEP}]
+ dev-python/pyqt6[dbus,designer,gui,help,multimedia,network,nfc,opengl]
+ dev-python/pyqt6[pdfium(-),positioning,printsupport,qml,quick,quick3d,serialport]
+ dev-python/pyqt6[sensors(-),spatialaudio(-),speech(-),sql,ssl,svg,testlib,webchannel]
+ dev-python/pyqt6[websockets,widgets,xml]
+ dev-python/pyqt6-webengine[${PYTHON_USEDEP},widgets,quick]
+ dev-qt/qtbase:6[sqlite]
+ )
+ pyside2? (
+ $(python_gen_cond_dep '
+ dev-python/pyside2[${PYTHON_USEDEP}]
+ dev-python/pyside2[3d,charts,concurrent,datavis,designer,gui,help]
+ dev-python/pyside2[location,multimedia,network,opengl(+)]
+ dev-python/pyside2[positioning,printsupport,qml,quick,scxml]
+ dev-python/pyside2[sensors,serialport(+),speech,sql,svg,testlib]
+ dev-python/pyside2[webchannel,webengine,websockets,widgets,x11extras]
+ dev-python/pyside2[xml,xmlpatterns]
+ dev-qt/qtsql:5[sqlite]
+ dev-python/pyside2-tools[${PYTHON_USEDEP}]
+ ' python3_{10..11})
+ dev-qt/qtsql:5[sqlite]
+ )
+ pyside6? (
+ dev-python/pyside6[${PYTHON_USEDEP}]
+ dev-python/pyside6[3d(-),bluetooth(-),concurrent,dbus,designer,gui,help]
+ dev-python/pyside6[location(-),multimedia,network,nfc(-),opengl,positioning,pdfium(-)]
+ dev-python/pyside6[printsupport,qml,quick,quick3d,scxml(-),sensors(-)]
+ dev-python/pyside6[serialport,spatialaudio(-),speech(-),sql,svg,testlib,webchannel]
+ dev-python/pyside6[webengine,websockets,widgets,xml]
+ dev-python/pyside6-tools[${PYTHON_USEDEP}]
+ dev-qt/qtbase:6[sqlite]
+ )
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+ sed -i -e 's:--cov=qtpy --cov-report=term-missing::' pytest.ini || die
+ # Disable Qt for Python implementations that are not selected
+ if ! use pyqt5; then
+ sed \
+ -e '/from PyQt5.QtCore import/,/)/c\ \ \ \ \ \ \ \ raise ImportError #/' \
+ -e '/if "PyQt5" in sys.modules:/,/"pyqt5"/c\' \
+ -i qtpy/__init__.py || die
+
+ # We need to ensure the first option is an 'if' not 'elif'
+ sed -e 's/elif "PySide2" in sys.modules:/if "PySide2" in sys.modules:/g' -i qtpy/__init__.py || die
+ fi
+ if ! use pyside2; then
+ sed \
+ -e "s/from PySide2 import/raise ImportError #/" \
+ -e "s/from PySide2.QtCore import/raise ImportError #/" \
+ -e '/if "PySide2" in sys.modules:/,/"pyside2"/c\' \
+ -i qtpy/__init__.py || die
+
+ if ! use pyqt5; then
+ sed \
+ -e 's/elif "PyQt6" in sys.modules:/if "PyQt6" in sys.modules:/g' \
+ -i qtpy/__init__.py || die
+ fi
+ fi
+ if ! use pyqt6; then
+ sed \
+ -e '/from PyQt6.QtCore import/,/)/c\ \ \ \ \ \ \ \ raise ImportError #/' \
+ -e '/if "PyQt6" in sys.modules:/,/"pyqt6"/c\' \
+ -i qtpy/__init__.py || die
+
+ if ! use pyqt5 && ! use pyside2; then
+ sed \
+ -e 's/elif "PySide6" in sys.modules:/if "PySide6" in sys.modules:/g' \
+ -i qtpy/__init__.py || die
+ fi
+ fi
+ if ! use pyside6; then
+ sed \
+ -e "s/from PySide6 import/raise ImportError #/" \
+ -e "s/from PySide6.QtCore import/raise ImportError #/" \
+ -e '/if "PySide6" in sys.modules:/,/"pyside6"/c\' \
+ -i qtpy/__init__.py || die
+ fi
+}
+
+python_test() {
+ local -x QT_API
+ local -a EPYTEST_DESELECT
+ local other
+
+ # Test for each enabled Qt4Python target.
+ # Deselect the other targets, their test fails if we specify QT_API
+ # or if we have disabled their corresponding inherit in __init__.py above
+ for QT_API in PyQt{5,6} PySide{2,6}; do
+ if use "${QT_API,,}"; then
+ EPYTEST_DESELECT=()
+ for other in PyQt{5,6} PySide{2,6}; do
+ if [[ ${QT_API} != ${other} ]]; then
+ EPYTEST_DESELECT+=(
+ "qtpy/tests/test_main.py::test_qt_api_environ[${other}]"
+ )
+ fi
+ done
+
+ einfo "Testing with ${EPYTHON} and QT_API=${QT_API}"
+ nonfatal epytest ||
+ die -n "Tests failed with ${EPYTHON} and QT_API=${QT_API}" ||
+ return 1
+ fi
+ done
+}
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+pkg_postinst() {
+ elog "When multiple Qt4Python targets are enabled QtPy will default to"
+ elog "the first enabled target in this order: PyQt5 PySide2 PyQt6 PySide6."
+ elog "This can be overridden with the QT_API environment variable."
+}
diff --git a/dev-python/qtpy/qtpy-2.4.2.ebuild b/dev-python/qtpy/qtpy-2.4.2.ebuild
new file mode 100644
index 000000000000..cc6c93a759a9
--- /dev/null
+++ b/dev-python/qtpy/qtpy-2.4.2.ebuild
@@ -0,0 +1,244 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_PN=QtPy
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 virtualx pypi
+
+DESCRIPTION="Abstraction layer on top of PyQt and PySide with additional custom QWidgets"
+HOMEPAGE="
+ https://github.com/spyder-ide/qtpy/
+ https://pypi.org/project/QtPy/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+_IUSE_QT_MODULES="
+ designer +gui help multimedia +network opengl positioning
+ printsupport qml quick sensors serialport speech +sql svg testlib
+ webchannel webengine websockets +widgets +xml
+"
+IUSE="+pyqt5 +pyqt6 pyside2 pyside6 ${_IUSE_QT_MODULES}"
+unset _IUSE_QT_MODULES
+
+REQUIRED_USE="
+ || ( pyqt5 pyqt6 pyside2 pyside6 )
+ python_targets_python3_12? ( !pyside2 )
+ python_targets_python3_13? ( !pyside2 )
+"
+
+# These flags are currently *not* common to the PySide2/6 and PyQt5/6 ebuilds
+# Disable them for now, please check periodically if this is still up to date.
+# bluetooth? ( pyqt5/6 and pyside6 only )
+# dbus? ( pyqt5/6 and pyside6 only )
+#
+# 3d? ( pyside2/6 only )
+# charts? ( pyside2 only )
+# concurrent? ( pyside2 only )
+# datavis? ( pyside2 only )
+# scxml? ( pyside2/6 only )
+#
+# x11extras? ( pyside2 and pyqt5 only )
+# xmlpatterns? ( pyside2 and pyqt5 only )
+#
+# location? ( pyside2/6 and pyqt5 only)
+# nfc? ( pyqt6 and pyside6 only)
+# spatialaudio? ( pyqt6 and pyside6 only)
+# pdfium? ( pyqt6 and pyside6 only)
+
+# WARNING: the obvious solution of using || for PyQt5/pyside2 is not going
+# to work. The package only checks whether PyQt5/pyside2 is installed, it does
+# not verify whether they have the necessary modules (i.e. satisfy the USE dep).
+#
+# Webengine is a special case, because PyQt5 provides this in a separate package
+# while PySide2 ships it in the same package.
+#
+# declarative/qml/quick is a special case, because PyQt5 bundles the bindings
+# for qml and quick in one flag: declarative PySide2 does not.
+#
+# The PyQt5 ebuild currently enables xml support unconditionally, the flag is
+# added anyway with a (+) to make it future proof if the ebuild were to change
+# this behaviour in the future.
+#
+# The PySide2 ebuild currently enables opengl and serialport support
+# unconditionally, the flag is added anyway with a (+) to make it future proof
+# if the ebuild were to change this behaviour in the future.
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ pyqt5? (
+ dev-python/pyqt5[${PYTHON_USEDEP}]
+ dev-python/pyqt5[designer?,gui?,help?,multimedia?,network?,opengl?]
+ dev-python/pyqt5[positioning?,printsupport?,sensors?,serialport?,speech?,sql?,svg?]
+ dev-python/pyqt5[testlib?,webchannel?,websockets?,widgets?,xml(+)?]
+ qml? ( dev-python/pyqt5[declarative] )
+ quick? ( dev-python/pyqt5[declarative] )
+ webengine? ( dev-python/pyqtwebengine[${PYTHON_USEDEP}] )
+ )
+ pyqt6? (
+ dev-python/pyqt6[${PYTHON_USEDEP}]
+ dev-python/pyqt6[designer?,gui?,help?,multimedia?,network?,opengl?]
+ dev-python/pyqt6[positioning?,printsupport?,qml?,quick?,sensors?,serialport?,sql?]
+ dev-python/pyqt6[speech?,svg?,testlib?,webchannel?,websockets?,widgets?,xml?]
+ webengine? ( dev-python/pyqt6-webengine[${PYTHON_USEDEP},widgets?,quick?] )
+
+ )
+ pyside2? (
+ $(python_gen_cond_dep '
+ dev-python/pyside2[${PYTHON_USEDEP}]
+ dev-python/pyside2[designer?,gui?,help?,multimedia?,network?,opengl(+)?]
+ dev-python/pyside2[positioning?,printsupport?,qml?,quick?,sensors?,serialport(+)?]
+ dev-python/pyside2[speech?,sql?,svg?,testlib?,webchannel?,webengine?,websockets?]
+ dev-python/pyside2[widgets?,xml?]
+ ' python3_{10..11})
+ )
+ pyside6? (
+ dev-python/pyside6[${PYTHON_USEDEP}]
+ dev-python/pyside6[designer?,gui?,help?,multimedia?,network?,opengl?]
+ dev-python/pyside6[positioning?,printsupport?,qml?,quick?,sensors(-)?,serialport?]
+ dev-python/pyside6[speech(-)?,sql?,svg?,testlib?,webchannel?,webengine?,websockets?]
+ dev-python/pyside6[widgets?,xml?]
+ )
+"
+
+# The QtPy testsuite skips tests for bindings that are not installed, so here we
+# ensure that everything is available and all tests are run. Note that not
+# all flags are available in PyQt5/PySide2, so some tests are still skipped.
+BDEPEND="
+ test? (
+ dev-python/pytest-qt[${PYTHON_USEDEP}]
+ pyqt5? (
+ dev-python/pyqt5[${PYTHON_USEDEP}]
+ dev-python/pyqt5[bluetooth,dbus,declarative,designer,gui,help,location]
+ dev-python/pyqt5[multimedia,network,opengl,positioning,printsupport]
+ dev-python/pyqt5[sensors,serialport,speech(-),sql,svg,testlib,webchannel]
+ dev-python/pyqt5[websockets,widgets,x11extras,xml(+),xmlpatterns]
+ dev-python/pyqtwebengine[${PYTHON_USEDEP}]
+ dev-qt/qtsql:5[sqlite]
+ )
+ pyqt6? (
+ dev-python/pyqt6[${PYTHON_USEDEP}]
+ dev-python/pyqt6[dbus,designer,gui,help,multimedia,network,nfc,opengl]
+ dev-python/pyqt6[pdfium(-),positioning,printsupport,qml,quick,quick3d,serialport]
+ dev-python/pyqt6[sensors(-),spatialaudio(-),speech(-),sql,ssl,svg,testlib,webchannel]
+ dev-python/pyqt6[websockets,widgets,xml]
+ dev-python/pyqt6-webengine[${PYTHON_USEDEP},widgets,quick]
+ dev-qt/qtbase:6[sqlite]
+ )
+ pyside2? (
+ $(python_gen_cond_dep '
+ dev-python/pyside2[${PYTHON_USEDEP}]
+ dev-python/pyside2[3d,charts,concurrent,datavis,designer,gui,help]
+ dev-python/pyside2[location,multimedia,network,opengl(+)]
+ dev-python/pyside2[positioning,printsupport,qml,quick,scxml]
+ dev-python/pyside2[sensors,serialport(+),speech,sql,svg,testlib]
+ dev-python/pyside2[webchannel,webengine,websockets,widgets,x11extras]
+ dev-python/pyside2[xml,xmlpatterns]
+ dev-qt/qtsql:5[sqlite]
+ dev-python/pyside2-tools[${PYTHON_USEDEP}]
+ ' python3_{10..11})
+ dev-qt/qtsql:5[sqlite]
+ )
+ pyside6? (
+ dev-python/pyside6[${PYTHON_USEDEP}]
+ dev-python/pyside6[3d(-),bluetooth(-),concurrent,dbus,designer,gui,help]
+ dev-python/pyside6[location(-),multimedia,network,nfc(-),opengl,positioning,pdfium(-)]
+ dev-python/pyside6[printsupport,qml,quick,quick3d,scxml(-),sensors(-)]
+ dev-python/pyside6[serialport,spatialaudio(-),speech(-),sql,svg,testlib,webchannel]
+ dev-python/pyside6[webengine,websockets,widgets,xml]
+ dev-python/pyside6-tools[${PYTHON_USEDEP}]
+ dev-qt/qtbase:6[sqlite]
+ )
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+ sed -i -e 's:--cov=qtpy --cov-report=term-missing::' pytest.ini || die
+ # Disable Qt for Python implementations that are not selected
+ if ! use pyqt5; then
+ sed \
+ -e '/from PyQt5.QtCore import/,/)/c\ \ \ \ \ \ \ \ raise ImportError #/' \
+ -e '/if "PyQt5" in sys.modules:/,/"pyqt5"/c\' \
+ -i qtpy/__init__.py || die
+
+ # We need to ensure the first option is an 'if' not 'elif'
+ sed -e 's/elif "PySide2" in sys.modules:/if "PySide2" in sys.modules:/g' -i qtpy/__init__.py || die
+ fi
+ if ! use pyside2; then
+ sed \
+ -e "s/from PySide2 import/raise ImportError #/" \
+ -e "s/from PySide2.QtCore import/raise ImportError #/" \
+ -e '/if "PySide2" in sys.modules:/,/"pyside2"/c\' \
+ -i qtpy/__init__.py || die
+
+ if ! use pyqt5; then
+ sed \
+ -e 's/elif "PyQt6" in sys.modules:/if "PyQt6" in sys.modules:/g' \
+ -i qtpy/__init__.py || die
+ fi
+ fi
+ if ! use pyqt6; then
+ sed \
+ -e '/from PyQt6.QtCore import/,/)/c\ \ \ \ \ \ \ \ raise ImportError #/' \
+ -e '/if "PyQt6" in sys.modules:/,/"pyqt6"/c\' \
+ -i qtpy/__init__.py || die
+
+ if ! use pyqt5 && ! use pyside2; then
+ sed \
+ -e 's/elif "PySide6" in sys.modules:/if "PySide6" in sys.modules:/g' \
+ -i qtpy/__init__.py || die
+ fi
+ fi
+ if ! use pyside6; then
+ sed \
+ -e "s/from PySide6 import/raise ImportError #/" \
+ -e "s/from PySide6.QtCore import/raise ImportError #/" \
+ -e '/if "PySide6" in sys.modules:/,/"pyside6"/c\' \
+ -i qtpy/__init__.py || die
+ fi
+}
+
+python_test() {
+ local -x QT_API
+ local -a EPYTEST_DESELECT
+ local other
+
+ # Test for each enabled Qt4Python target.
+ # Deselect the other targets, their test fails if we specify QT_API
+ # or if we have disabled their corresponding inherit in __init__.py above
+ for QT_API in PyQt{5,6} PySide{2,6}; do
+ if use "${QT_API,,}"; then
+ EPYTEST_DESELECT=()
+ for other in PyQt{5,6} PySide{2,6}; do
+ if [[ ${QT_API} != ${other} ]]; then
+ EPYTEST_DESELECT+=(
+ "qtpy/tests/test_main.py::test_qt_api_environ[${other}]"
+ )
+ fi
+ done
+
+ einfo "Testing with ${EPYTHON} and QT_API=${QT_API}"
+ nonfatal epytest -o addopts= ||
+ die -n "Tests failed with ${EPYTHON} and QT_API=${QT_API}" ||
+ return 1
+ fi
+ done
+}
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+pkg_postinst() {
+ elog "When multiple Qt4Python targets are enabled QtPy will default to"
+ elog "the first enabled target in this order: PyQt5 PySide2 PyQt6 PySide6."
+ elog "This can be overridden with the QT_API environment variable."
+}