summaryrefslogtreecommitdiff
path: root/dev-python/qtpy
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/qtpy')
-rw-r--r--dev-python/qtpy/Manifest3
-rw-r--r--dev-python/qtpy/metadata.xml1
-rw-r--r--dev-python/qtpy/qtpy-2.4.2.ebuild214
3 files changed, 1 insertions, 217 deletions
diff --git a/dev-python/qtpy/Manifest b/dev-python/qtpy/Manifest
index dcda11b452d8..ea7c06444392 100644
--- a/dev-python/qtpy/Manifest
+++ b/dev-python/qtpy/Manifest
@@ -1,6 +1,5 @@
DIST qtpy-2.4.2.tar.gz 66849 BLAKE2B 1eb362e797950d6c1406fb02bb3047ca7f8fdecd2b75371ab34f39601c9bdebce33336e3809c0d35dca31673c88d1734721a6dfdfb65f2ce20729445c4a4ca27 SHA512 2f9a0e1a4839c8dca23b4364900a12c2bd00f518353785a41eb6bd62fdc469670457f18224e1150a5a216ff5d0c4e799c3a1711ff7703ea07fadd655538fa37a
DIST qtpy-2.4.3.tar.gz 66982 BLAKE2B 92596eaac7be55feaecbfe2fad388ac3a7a5e55763dc794be2a70c081b311843f5dadb03dba06df6711c32ba9c68f18f54c35921b3ba6e2f02f20922ed89455a SHA512 9a12d9e7a8651309807d578e07075d1bd44a7e72b84b7761e80e80b115a492c9369d842a3cca32a438070d9fde2564d9a69d7a2470e9331d81b11469e2c9808a
EBUILD qtpy-2.4.2-r1.ebuild 6271 BLAKE2B 9bfa2a96e7fde10e49e3c3ad69b6bbfecb91dde5bfc3e02fde4769901151f66cad3e7689b92d067ed7aecb69f245b229516e13c860153e530f7f737070f98076 SHA512 0976c21c23cb3c7ef840cc3b2a067ad95602373e493a8b3356f3d3626710e68c4ba4b7512488320b3e35e59e8f8d9b4b4c7861d1c1cb2413915b638582a8e1ac
-EBUILD qtpy-2.4.2.ebuild 7572 BLAKE2B 104a18545476e86462ad794ad85de3edf92c6ff4532c0422933586724db77840c1ebb24ad0b7cdee12c0adcc705b8cb98621bc4b96a0b5c8b59e4ce83ac26d3a SHA512 cacfbc650f8ed234758d6588c7fcf5c67ade5d4bfe5c06f8120a204e8e6c18eded9e99d3fcd57663878c6430f312a415122d7fbfb83c4012671ce1bb6a92a752
EBUILD qtpy-2.4.3.ebuild 6330 BLAKE2B 1e2854b4f5b614c8f672b09c7c846a2db8ba520814f3b0fa11e4d361f444d757d2dc1ad9e7d7495eba8958ae79fad1c64c68ab75ffaf02897faee87be3e47e73 SHA512 b79ce8b82cd132f9103ab91338d8c8a28351a079249bb36e694c87bce3ed6cd211332562fe60a11194fee8035268ade7412a4c8427547c0f87a781f37e722d02
-MISC metadata.xml 3089 BLAKE2B d7b38abc29fdd333308dac5f588de6a84f35f1b8f64df18952d8524295ede947cb83ae5ff083bae4af4caf9883463ced682fe83b6f9b654e2da773c2b94548b9 SHA512 825ba4cf6b13703370cf4377cd71478df42cc8bce91b68ad7a6084b286cbd0ba9ec9a20025f848ecfdaeb97298724ffd563b20e0268c050e3817c7ec589c8c5e
+MISC metadata.xml 2997 BLAKE2B c128625e8cf6e73392e66862ccef04e2d129efd41c0226be3d6e498c410108e66451f2a1e2455bbfffff8e1287c17ec7a54fcb8db4f187088c423b7d46f87161 SHA512 e7ac53d191e3a714c011968c76a1bbc23747f115e022ffa08b83ae1f85a0f98a7824a76e199ed36dd5cc8c2356051eaa4c0768ae2e7f85ddfb489b54b501188f
diff --git a/dev-python/qtpy/metadata.xml b/dev-python/qtpy/metadata.xml
index fe0e7db3605b..1f0759022b9b 100644
--- a/dev-python/qtpy/metadata.xml
+++ b/dev-python/qtpy/metadata.xml
@@ -15,7 +15,6 @@
Basically, you can write your code as if you were using PyQt6 but import Qt modules from qtpy instead of PyQt6 (or PySide6)
</longdescription>
<use>
- <flag name="pyqt5">Use <pkg>dev-python/pyqt5</pkg> as Qt for Python implementation</flag>
<flag name="pyqt6">Use <pkg>dev-python/pyqt6</pkg> as Qt for Python implementation</flag>
<flag name="pyside6">Use <pkg>dev-python/pyside</pkg> as Qt for Python implementation</flag>
<flag name="designer">Pull in bindings for the QtDesigner module and enable the designer plugin</flag>
diff --git a/dev-python/qtpy/qtpy-2.4.2.ebuild b/dev-python/qtpy/qtpy-2.4.2.ebuild
deleted file mode 100644
index 1abaea78d5d5..000000000000
--- a/dev-python/qtpy/qtpy-2.4.2.ebuild
+++ /dev/null
@@ -1,214 +0,0 @@
-# Copyright 1999-2025 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_PN=QtPy
-PYTHON_COMPAT=( python3_{10..13} )
-
-inherit distutils-r1 virtualx pypi
-
-DESCRIPTION="Abstraction layer on top of PyQt and PySide with additional custom QWidgets"
-HOMEPAGE="
- https://github.com/spyder-ide/qtpy/
- https://pypi.org/project/QtPy/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~loong ~ppc64 ~riscv x86"
-
-_IUSE_QT_MODULES="
- designer +gui help multimedia +network opengl positioning
- printsupport qml quick sensors serialport speech +sql svg testlib
- webchannel webengine websockets +widgets +xml
-"
-IUSE="+pyqt5 +pyqt6 pyside6 ${_IUSE_QT_MODULES}"
-unset _IUSE_QT_MODULES
-
-REQUIRED_USE="|| ( pyqt5 pyqt6 pyside6 )"
-
-# These flags are currently *not* common to the PySide2/6 and PyQt5/6 ebuilds
-# Disable them for now, please check periodically if this is still up to date.
-# bluetooth? ( pyqt5/6 and pyside6 only )
-# dbus? ( pyqt5/6 and pyside6 only )
-#
-# 3d? ( pyside2/6 only )
-# charts? ( pyside2 only )
-# concurrent? ( pyside2 only )
-# datavis? ( pyside2 only )
-# scxml? ( pyside2/6 only )
-#
-# x11extras? ( pyside2 and pyqt5 only )
-# xmlpatterns? ( pyside2 and pyqt5 only )
-#
-# location? ( pyside2/6 and pyqt5 only)
-# nfc? ( pyqt6 and pyside6 only)
-# spatialaudio? ( pyqt6 and pyside6 only)
-# pdfium? ( pyqt6 and pyside6 only)
-
-# WARNING: the obvious solution of using || for PyQt5/pyside2 is not going
-# to work. The package only checks whether PyQt5/pyside2 is installed, it does
-# not verify whether they have the necessary modules (i.e. satisfy the USE dep).
-#
-# Webengine is a special case, because PyQt5 provides this in a separate package
-# while PySide2 ships it in the same package.
-#
-# declarative/qml/quick is a special case, because PyQt5 bundles the bindings
-# for qml and quick in one flag: declarative PySide2 does not.
-#
-# The PyQt5 ebuild currently enables xml support unconditionally, the flag is
-# added anyway with a (+) to make it future proof if the ebuild were to change
-# this behaviour in the future.
-#
-# The PySide2 ebuild currently enables opengl and serialport support
-# unconditionally, the flag is added anyway with a (+) to make it future proof
-# if the ebuild were to change this behaviour in the future.
-RDEPEND="
- dev-python/packaging[${PYTHON_USEDEP}]
- pyqt5? (
- dev-python/pyqt5[${PYTHON_USEDEP}]
- dev-python/pyqt5[designer?,gui?,help?,multimedia?,network?,opengl?]
- dev-python/pyqt5[positioning(-)?,printsupport?,sensors(-)?,serialport?,speech?,sql?,svg?]
- dev-python/pyqt5[testlib?,webchannel?,websockets?,widgets?,xml(+)?]
- qml? ( dev-python/pyqt5[declarative] )
- quick? ( dev-python/pyqt5[declarative] )
- webengine? ( dev-python/pyqtwebengine[${PYTHON_USEDEP}] )
- )
- pyqt6? (
- dev-python/pyqt6[${PYTHON_USEDEP}]
- dev-python/pyqt6[designer?,gui?,help?,multimedia?,network?,opengl?]
- dev-python/pyqt6[positioning?,printsupport?,qml?,quick?,sensors?,serialport?,sql?]
- dev-python/pyqt6[speech?,svg?,testlib?,webchannel?,websockets?,widgets?,xml?]
- webengine? ( dev-python/pyqt6-webengine[${PYTHON_USEDEP},widgets?,quick?] )
-
- )
- pyside6? (
- dev-python/pyside[${PYTHON_USEDEP},core(+)]
- dev-python/pyside[designer?,gui?,help?,multimedia?,network?,opengl?]
- dev-python/pyside[positioning?,printsupport?,qml?,quick?,sensors(-)?,serialport?]
- dev-python/pyside[speech(-)?,sql?,svg?,testlib?,webchannel?,webengine?,websockets?]
- dev-python/pyside[widgets?,xml?]
- )
-"
-
-# The QtPy testsuite skips tests for bindings that are not installed, so here we
-# ensure that everything is available and all tests are run. Note that not
-# all flags are available in PyQt5/PySide2, so some tests are still skipped.
-BDEPEND="
- test? (
- dev-python/pytest-qt[${PYTHON_USEDEP}]
- pyqt5? (
- dev-python/pyqt5[${PYTHON_USEDEP}]
- dev-python/pyqt5[dbus,declarative,designer,gui,help]
- dev-python/pyqt5[multimedia,network,opengl,printsupport]
- dev-python/pyqt5[serialport,speech(-),sql,svg,testlib,webchannel]
- dev-python/pyqt5[websockets,widgets,x11extras,xml(+),xmlpatterns]
- dev-python/pyqtwebengine[${PYTHON_USEDEP}]
- dev-qt/qtsql:5[sqlite]
- )
- pyqt6? (
- dev-python/pyqt6[${PYTHON_USEDEP}]
- dev-python/pyqt6[dbus,designer,gui,help,multimedia,network,nfc,opengl]
- dev-python/pyqt6[pdfium(-),positioning,printsupport,qml,quick,quick3d,serialport]
- dev-python/pyqt6[sensors(-),spatialaudio(-),speech(-),sql,ssl,svg,testlib,webchannel]
- dev-python/pyqt6[websockets,widgets,xml]
- dev-python/pyqt6-webengine[${PYTHON_USEDEP},widgets,quick]
- dev-qt/qtbase:6[sqlite]
- )
- pyside6? (
- dev-python/pyside[${PYTHON_USEDEP},core(+)]
- dev-python/pyside[3d(-),bluetooth(-),concurrent,dbus,designer,gui,help]
- dev-python/pyside[location(-),multimedia,network,nfc(-),opengl,positioning,pdfium(-)]
- dev-python/pyside[printsupport,qml,quick,quick3d,scxml(-),sensors(-)]
- dev-python/pyside[serialport,spatialaudio(-),speech(-),sql,svg,testlib,webchannel]
- dev-python/pyside[webengine,websockets,widgets,xml]
- dev-qt/qtbase:6[sqlite]
- )
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- distutils-r1_src_prepare
- sed -i -e 's:--cov=qtpy --cov-report=term-missing::' pytest.ini || die
- # Disable Qt for Python implementations that are not selected
- if ! use pyqt5; then
- sed \
- -e '/from PyQt5.QtCore import/,/)/c\ \ \ \ \ \ \ \ raise ImportError #/' \
- -e '/if "PyQt5" in sys.modules:/,/"pyqt5"/c\' \
- -i qtpy/__init__.py || die
-
- # We need to ensure the first option is an 'if' not 'elif'
- sed -e 's/elif "PySide2" in sys.modules:/if "PySide2" in sys.modules:/g' -i qtpy/__init__.py || die
- fi
- sed \
- -e "s/from PySide2 import/raise ImportError #/" \
- -e "s/from PySide2.QtCore import/raise ImportError #/" \
- -e '/if "PySide2" in sys.modules:/,/"pyside2"/c\' \
- -i qtpy/__init__.py || die
-
- if ! use pyqt5; then
- sed \
- -e 's/elif "PyQt6" in sys.modules:/if "PyQt6" in sys.modules:/g' \
- -i qtpy/__init__.py || die
- fi
- if ! use pyqt6; then
- sed \
- -e '/from PyQt6.QtCore import/,/)/c\ \ \ \ \ \ \ \ raise ImportError #/' \
- -e '/if "PyQt6" in sys.modules:/,/"pyqt6"/c\' \
- -i qtpy/__init__.py || die
-
- if ! use pyqt5; then
- sed \
- -e 's/elif "PySide6" in sys.modules:/if "PySide6" in sys.modules:/g' \
- -i qtpy/__init__.py || die
- fi
- fi
- if ! use pyside6; then
- sed \
- -e "s/from PySide6 import/raise ImportError #/" \
- -e "s/from PySide6.QtCore import/raise ImportError #/" \
- -e '/if "PySide6" in sys.modules:/,/"pyside6"/c\' \
- -i qtpy/__init__.py || die
- fi
-}
-
-python_test() {
- local -x QT_API
- local -a EPYTEST_DESELECT
- local other
-
- # Test for each enabled Qt4Python target.
- # Deselect the other targets, their test fails if we specify QT_API
- # or if we have disabled their corresponding inherit in __init__.py above
- for QT_API in PyQt{5,6} PySide{2,6}; do
- if use "${QT_API,,}"; then
- EPYTEST_DESELECT=()
- for other in PyQt{5,6} PySide{2,6}; do
- if [[ ${QT_API} != ${other} ]]; then
- EPYTEST_DESELECT+=(
- "qtpy/tests/test_main.py::test_qt_api_environ[${other}]"
- )
- fi
- done
-
- einfo "Testing with ${EPYTHON} and QT_API=${QT_API}"
- nonfatal epytest -o addopts= ||
- die -n "Tests failed with ${EPYTHON} and QT_API=${QT_API}" ||
- return 1
- fi
- done
-}
-
-src_test() {
- virtx distutils-r1_src_test
-}
-
-pkg_postinst() {
- elog "When multiple Qt4Python targets are enabled QtPy will default to"
- elog "the first enabled target in this order: PyQt5 PySide2 PyQt6 PySide6."
- elog "This can be overridden with the QT_API environment variable."
-}