summaryrefslogtreecommitdiff
path: root/dev-python/quart-trio
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/quart-trio')
-rw-r--r--dev-python/quart-trio/Manifest5
-rw-r--r--dev-python/quart-trio/files/quart-trio-0.11.1-trio-0.25.patch73
-rw-r--r--dev-python/quart-trio/quart-trio-0.11.1.ebuild48
-rw-r--r--dev-python/quart-trio/quart-trio-0.12.0.ebuild2
4 files changed, 2 insertions, 126 deletions
diff --git a/dev-python/quart-trio/Manifest b/dev-python/quart-trio/Manifest
index db5578a669dd..56d8e24c1294 100644
--- a/dev-python/quart-trio/Manifest
+++ b/dev-python/quart-trio/Manifest
@@ -1,6 +1,3 @@
-AUX quart-trio-0.11.1-trio-0.25.patch 2490 BLAKE2B f4430630bcd8151343367804bb179863b89826c98a4893b06672c0930b6153c748b1850acc259a547fbb52d41d8b6a94eb6af80327a83e8234aec366669d93e2 SHA512 04bdeb63b4de4b3fff472bdd0eb8dbdb87a0a73f48ceaaec85d0e0747b56bd0c520b0c75ab09fa43c1dc0cb296e180b8dd3496ac43e115b5cc8f562e5dcde006
-DIST quart-trio-0.11.1.gh.tar.gz 18568 BLAKE2B faabf4204a82dcc70e41d1d1ec7171c89386f2e40979c20501890d9bc27eb2af693bc791a9015a9c4c676a5e25ec69dc4975a0cd09987cd14f699a04442d54da SHA512 8ea20c36c772eff3e2b0a83a4c325cd223c19b3d7e1e51e7378897bd11479db2c8015d2e8c4713721070fc413f42b19f844a3966a0d06d299439cf514b0b3291
DIST quart_trio-0.12.0.tar.gz 14979 BLAKE2B 7a7ffaba59e6984001941c1c54cfab189434366ab1b56d6509567c79560d916e2a5f0c81e8f23e17462de17d012d77eda3803cc8828a5378b3b92c1bab00e475 SHA512 70b1f2406185b020f999cb335c2c13599faf9c36c69f8adc437fbb846158f659e8d6527199083f9674e75c99bcd10dbf228dbd62ca7c5614b471c462b22227ee
-EBUILD quart-trio-0.11.1.ebuild 1099 BLAKE2B 1e3e0dfa6b0b711fb316a6cfc562becacfab33b2b33e9bd7c98c689716b6e4ad94222d47a11237eb52499d6d7d7443100395e5215f4c6a49d331ba51277b4acb SHA512 5af16fa1045b9b9aae2ec10d6ff6359b5081535eed01bb060c9ba661ecfb761e07ce5bc636a0eca967be02113e1639f548cbdae37c50302a14b7b66590c40678
-EBUILD quart-trio-0.12.0.ebuild 892 BLAKE2B 1c174d623cb5369758e49bf42b9e27496c9c34fdd84255d3b4439dadae3fb03e73149363d7d77a91080911696c2a8da1412f307c493e357e30a71b1361f92e07 SHA512 3a23c94cfdf94271ca571e793223eeda57b985d37d423acbf8052b7df8f5953fc3b6035d018fcde59a77a9cade66a0efb67010b6518f3d79db7c81fe6686b21d
+EBUILD quart-trio-0.12.0.ebuild 885 BLAKE2B bb583b6d817b32e8fa24e05f898b84053f009da389d517e050f4c46313b1108781f2ad8275b46dd55134ddd54d4634c0a0225dc372505acef6768fd07cd2b9bd SHA512 f527be5bfb0cead38b4cb927610508da613a3d37db1244cd87b3304e305354d7fc5cadc15a3e20d3c0f0a914673e31017610e72439cde7bfd6186cba9f403aab
MISC metadata.xml 427 BLAKE2B fade855b0fc05b078dec5432d1e5cff22bdc4fc23bb97aecca815b7c031b67881f291afae0d5abf42fc115f405cf528683d992447d372a154015c40b1eb8f36c SHA512 2738f87b35ee3ca112096727054730fe90af48a3f77afff7aed8198a43bf505e984ec0f2d810fcd183507be58a8586c6f3dd4dcd26f40c6ba11008d7745aa714
diff --git a/dev-python/quart-trio/files/quart-trio-0.11.1-trio-0.25.patch b/dev-python/quart-trio/files/quart-trio-0.11.1-trio-0.25.patch
deleted file mode 100644
index f95a253d06e9..000000000000
--- a/dev-python/quart-trio/files/quart-trio-0.11.1-trio-0.25.patch
+++ /dev/null
@@ -1,73 +0,0 @@
-From 805686abfd9963be26d59d9da9b11faddd583d11 Mon Sep 17 00:00:00 2001
-From: pgjones <philip.graham.jones@googlemail.com>
-Date: Sun, 19 May 2024 15:03:24 +0100
-Subject: [PATCH] Fix test failures
-
-Catch and extract from ExceptionGroups
----
- tests/test_app.py | 14 +++++++++-----
- tests/test_basic.py | 10 ++++++++--
- 2 files changed, 17 insertions(+), 7 deletions(-)
-
-diff --git a/tests/test_app.py b/tests/test_app.py
-index b6bffb5..1585107 100644
---- a/tests/test_app.py
-+++ b/tests/test_app.py
-@@ -51,8 +51,10 @@ async def handler(_: Exception) -> ResponseReturnValue:
- try:
- async with test_client.websocket("/ws/") as test_websocket:
- await test_websocket.receive()
-- except WebsocketResponseError as error:
-- assert error.response.status_code == 201
-+ except BaseExceptionGroup as error:
-+ for exception in error.exceptions:
-+ if isinstance(exception, WebsocketResponseError):
-+ assert exception.response.status_code == 201
-
-
- @pytest.mark.trio
-@@ -68,8 +70,10 @@ async def test_websocket_exception_group_unhandled(error_app: QuartTrio) -> None
- try:
- async with test_client.websocket("/ws/") as test_websocket:
- await test_websocket.receive()
-- except WebsocketResponseError as error:
-- assert error.response.status_code == 500
-+ except BaseExceptionGroup as error:
-+ for exception in error.exceptions:
-+ if isinstance(exception, WebsocketResponseError):
-+ assert exception.response.status_code == 500
-
-
- @pytest.mark.trio
-diff --git a/tests/test_basic.py b/tests/test_basic.py
-index 5cc4c4a..a483678 100644
---- a/tests/test_basic.py
-+++ b/tests/test_basic.py
-@@ -1,3 +1,4 @@
-+import sys
- from pathlib import Path
-
- import pytest
-@@ -6,6 +7,9 @@
-
- from quart_trio import QuartTrio
-
-+if sys.version_info < (3, 11):
-+ from exceptiongroup import BaseExceptionGroup
-+
-
- @pytest.fixture
- def app() -> Quart:
-@@ -53,8 +57,10 @@ async def test_websocket_abort(app: Quart) -> None:
- try:
- async with test_client.websocket("/ws/abort/") as test_websocket:
- await test_websocket.receive()
-- except WebsocketResponseError as error:
-- assert error.response.status_code == 401
-+ except BaseExceptionGroup as error:
-+ for exception in error.exceptions:
-+ if isinstance(exception, WebsocketResponseError):
-+ assert exception.response.status_code == 401
-
-
- @pytest.mark.trio
diff --git a/dev-python/quart-trio/quart-trio-0.11.1.ebuild b/dev-python/quart-trio/quart-trio-0.11.1.ebuild
deleted file mode 100644
index ec8cf463b5d3..000000000000
--- a/dev-python/quart-trio/quart-trio-0.11.1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( pypy3 python3_{10..13} )
-
-inherit distutils-r1
-
-DESCRIPTION="A Quart extension to provide trio support"
-HOMEPAGE="
- https://github.com/pgjones/quart-trio/
- https://pypi.org/project/quart-trio/
-"
-# no tests in sdist, as of 0.11.1
-SRC_URI="
- https://github.com/pgjones/quart-trio/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/exceptiongroup-1.0.0[${PYTHON_USEDEP}]
- >=dev-python/hypercorn-0.12.0[${PYTHON_USEDEP}]
- >=dev-python/quart-0.19[${PYTHON_USEDEP}]
- >=dev-python/trio-0.19.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/pytest-trio[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- # https://github.com/pgjones/quart-trio/commit/805686abfd9963be26d59d9da9b11faddd583d11
- "${FILESDIR}/${P}-trio-0.25.patch"
-)
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -o addopts= -p trio
-}
diff --git a/dev-python/quart-trio/quart-trio-0.12.0.ebuild b/dev-python/quart-trio/quart-trio-0.12.0.ebuild
index 53640fe9bc8b..ca27793051aa 100644
--- a/dev-python/quart-trio/quart-trio-0.12.0.ebuild
+++ b/dev-python/quart-trio/quart-trio-0.12.0.ebuild
@@ -16,7 +16,7 @@ HOMEPAGE="
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+KEYWORDS="amd64 arm arm64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
RDEPEND="
$(python_gen_cond_dep '