summaryrefslogtreecommitdiff
path: root/dev-python/rebulk
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/rebulk')
-rw-r--r--dev-python/rebulk/Manifest3
-rw-r--r--dev-python/rebulk/rebulk-0.9.0.ebuild17
-rw-r--r--dev-python/rebulk/rebulk-9999.ebuild41
3 files changed, 4 insertions, 57 deletions
diff --git a/dev-python/rebulk/Manifest b/dev-python/rebulk/Manifest
index ab50f5e33cb1..132e0d152758 100644
--- a/dev-python/rebulk/Manifest
+++ b/dev-python/rebulk/Manifest
@@ -1,4 +1,3 @@
DIST rebulk-0.9.0.tar.gz 257342 BLAKE2B a08b2d74685eea35597331bb2ef3c48e8a9cddc39ad3821cb7f33b80a47184a21f813b339e9d64548b3003913178191075455a6f787ab80ffa2cb3bf7f0db35d SHA512 25a22b3a5f5519f6f8c10abf6a477f212c0500264cfdcc5a9be09d3818462a051b1a7cd78f94991c44ac6bcdc7435b9909e65de48d1bd8138989e0da98d10262
-EBUILD rebulk-0.9.0.ebuild 945 BLAKE2B 0775cfb865b34acabf7d49cd6498ae4e6eafb6c5adc697088f17599587497a7c84e6c666ba6024cd03fbcda00ecc218a7f99eb09f1bc9d543f476326b9f27ada SHA512 5728e64c71d91dc189b2d470bae985616a2cad48b09570ff01156d72fe15fa1b00da5b15635f71242a6db9fc319f1e86c48f1ab9f5e945de353ed7a647274ebd
-EBUILD rebulk-9999.ebuild 943 BLAKE2B 05663aaa933d5f33758022945588acd20d6213dc892e2475d5ee6f8d1a0cc63513ff0cfd790087d078245bd83a23daf7a2b30fb28ae4ecd1d4544e1df4c0248c SHA512 3db608daab224b823d8c5c1a692aeb8326aa656e22595d45ca137d3769ed4d90f035ea4f89aae56eda734891836b1595b0cf3e6f3a55526cbf0787d03e604f46
+EBUILD rebulk-0.9.0.ebuild 749 BLAKE2B a5c16f951c8bbdf29ea59f5ad5759a6b19d9ac8d021d685a5a9603047d5a58574888afb32bc9dde66be58a3d7ff336cc6a861d804914fd9fefb193bb22ef261e SHA512 332309723fe9a988f14591f39c277050aaf55264826e9269663e2d2b065eb2fc1ef4faf5f0701505a04deccb934add19dccbc7c4c20b9046f0f07473b593c3ff
MISC metadata.xml 289 BLAKE2B 0b4705d4e9400951a5a9bbfd79a5f311cf4918e6665f697b8b94fc7daa4bb777457fd919d09f79627ab5cff49fdf473a4535146b0fb7decf33f1afe15b42d32f SHA512 d3d12fbd490d3b76d211a0a47691e7ed085b6bc6235e36ba5ddb6c976793cad1f206d61444d451da66ff16cc4e0bbc2208ce6fcee07fd8b52fe6a01e39417257
diff --git a/dev-python/rebulk/rebulk-0.9.0.ebuild b/dev-python/rebulk/rebulk-0.9.0.ebuild
index 4828cd9ec638..d0df2d1455ca 100644
--- a/dev-python/rebulk/rebulk-0.9.0.ebuild
+++ b/dev-python/rebulk/rebulk-0.9.0.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7} )
inherit distutils-r1
@@ -14,17 +14,10 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT Apache-2.0"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-runner[${PYTHON_USEDEP}]
- )
-"
+
+distutils_enable_tests pytest
python_prepare_all() {
# Remove base64-encoded zip archive with pytest.
@@ -35,7 +28,3 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
-
-python_test() {
- esetup.py test
-}
diff --git a/dev-python/rebulk/rebulk-9999.ebuild b/dev-python/rebulk/rebulk-9999.ebuild
deleted file mode 100644
index 88825450c608..000000000000
--- a/dev-python/rebulk/rebulk-9999.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1 git-r3
-
-DESCRIPTION="Python library that performs advanced searches in strings"
-HOMEPAGE="https://github.com/Toilal/rebulk https://pypi.org/project/rebulk/"
-EGIT_REPO_URI="https://github.com/Toilal/${PN}.git"
-
-LICENSE="MIT Apache-2.0"
-SLOT="0"
-KEYWORDS=""
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-runner[${PYTHON_USEDEP}]
- )
-"
-
-python_prepare_all() {
- # Remove base64-encoded zip archive with pytest.
- rm runtests.py || die
-
- # Disable unconditional dependency on dev-python/pytest-runner.
- sed -i -e "s|'pytest-runner'||g" setup.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- esetup.py test
-}