summaryrefslogtreecommitdiff
path: root/dev-python/redis
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/redis')
-rw-r--r--dev-python/redis/Manifest2
-rw-r--r--dev-python/redis/redis-6.0.0.ebuild114
2 files changed, 116 insertions, 0 deletions
diff --git a/dev-python/redis/Manifest b/dev-python/redis/Manifest
index fec8474305d3..d286df978643 100644
--- a/dev-python/redis/Manifest
+++ b/dev-python/redis/Manifest
@@ -1,3 +1,5 @@
DIST redis-py-5.2.1.gh.tar.gz 4824044 BLAKE2B 9adf1b7093d7e562782f0c17c9134f33326b19f6ae9895142eadf251165c7d8bed7e61eedc96360724602b42cde4e1f9a0a4193fa76a3de2e30b95268a2f5e2b SHA512 583495712b492558fa186a0b72f19576418fc49937e4e2c2716335f3b05f5c5da6dda149abe6a55ef1dc93284660348a5d545a69db0a1dde08218305f44e9f52
+DIST redis-py-6.0.0.gh.tar.gz 4853361 BLAKE2B a82f2c9d05c62c2e4fc310923d78ad9164c3fa4886f046f15261a97d843ff4478f7bd5ed283739424bcc9fe378265afaf00448aa954e537fecf0f1a3947d9f6e SHA512 72c91bc132dcc9cc32ed221b931c6315615dac9e4b1054638df6ed651f0ba787c319d59c22a001962efca40efcf73654ff012007cda4b277783cb2fa6a9cb9d6
EBUILD redis-5.2.1.ebuild 3171 BLAKE2B 0dfa85475d827f3f5853589830a235c9a5467461e1cc8cc0af9734de74a0c04bff039ce817c7ac9701da1a1b1587d73a320fab2d8167c1f32d7da79bf79f683d SHA512 5b1e7db1bc9fa4287232f89825fdbacf8bc72a038e4b06d7fcf739e24108ae36b97b26803d567ab326db0ecfeca4638f911fdf8cb977bb6ad956ca6aacd5bf03
+EBUILD redis-6.0.0.ebuild 3271 BLAKE2B e801725d54260e81c80e3a61a9ebffa53ec31452f31395b2d0ea8764db60bebab9b9fb3695768fb213dffbf8bf96912f45b9cdc65fb40ad4329e42f5e727376c SHA512 cd34850a0b666172267305fc80f8058929b277148f560a04b7d364d0bd066fef21873a65f0edb62138f59d46520f612050a6318db384890eda558a493242ef74
MISC metadata.xml 506 BLAKE2B 0e5747e826132dd365bdf6d3a63f0936ed476bc69c4c4d55126e692039046f51f69b193ead0baa181090b11f69ab2a49220d8f906f9fe3fc18331b76ff9e0b0f SHA512 725d650bfe345b132588930a18ade44182ec07f6697d2fd8806dc208ab1556939926e8899fc6d43691101d971f9c1e011fb8a5675fdde4698dbf4c230db15c75
diff --git a/dev-python/redis/redis-6.0.0.ebuild b/dev-python/redis/redis-6.0.0.ebuild
new file mode 100644
index 000000000000..b7b2a0aba98c
--- /dev/null
+++ b/dev-python/redis/redis-6.0.0.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} pypy3 pypy3_11 )
+
+inherit distutils-r1
+
+MY_P=redis-py-${PV}
+DESCRIPTION="Python client for Redis key-value store"
+HOMEPAGE="
+ https://github.com/redis/redis-py/
+ https://pypi.org/project/redis/
+"
+SRC_URI="
+ https://github.com/redis/redis-py/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/async-timeout-4.0.3[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ dev-db/redis
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # https://github.com/redis/redis-py/issues/3339
+ sed -i 's:(forbid_global_loop=True)::' tests/test_asyncio/*.py || die
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Flaky test
+ tests/test_pubsub.py::TestPubSubDeadlock::test_pubsub_deadlock
+ # require extra redis modules that apparently aren't packaged
+ # on Gentoo
+ tests/{,test_asyncio/}test_bloom.py
+ tests/{,test_asyncio/}test_graph.py
+ tests/{,test_asyncio/}test_json.py
+ tests/{,test_asyncio/}test_timeseries.py
+ # apparently available only in "Redis Stack 7.2 RC3 or later"
+ tests/test_commands.py::TestRedisCommands::test_tfunction_load_delete
+ tests/test_commands.py::TestRedisCommands::test_tfunction_list
+ tests/test_commands.py::TestRedisCommands::test_tfcall
+ # TODO
+ tests/test_commands.py::TestRedisCommands::test_module
+ tests/test_commands.py::TestRedisCommands::test_module_loadex
+ tests/test_commands.py::TestRedisCommands::test_zrank_withscore
+ tests/test_commands.py::TestRedisCommands::test_zrevrank_withscore
+ tests/test_commands.py::TestRedisCommands::test_xinfo_consumers
+ tests/test_asyncio/test_commands.py::TestRedisCommands::test_zrank_withscore
+ tests/test_asyncio/test_commands.py::TestRedisCommands::test_zrevrank_withscore
+ tests/test_asyncio/test_commands.py::TestRedisCommands::test_xinfo_consumers
+ tests/test_asyncio/test_pubsub.py::TestPubSubAutoReconnect::test_reconnect_socket_error[pool-hiredis-listen]
+ )
+ local EPYTEST_IGNORE=(
+ # fails over missing certs, we don't do cluster anyway
+ tests/test_asyncio/test_cluster.py
+ # require redis_entraid
+ tests/test_asyncio/test_credentials.py
+ tests/test_credentials.py
+ )
+
+ # TODO: try to run more servers?
+ epytest -m "not redismod and not onlycluster and not replica and not ssl"
+}
+
+src_test() {
+ local redis_pid="${T}"/redis.pid
+ local redis_port=6379
+
+ if has_version ">=dev-db/redis-7"; then
+ local extra_conf="
+ enable-debug-command yes
+ enable-module-command yes
+ "
+ fi
+
+ # Spawn Redis itself for testing purposes
+ einfo "Spawning Redis"
+ einfo "NOTE: Port ${redis_port} must be free"
+ "${EPREFIX}"/usr/sbin/redis-server - <<- EOF || die "Unable to start redis server"
+ daemonize yes
+ pidfile ${redis_pid}
+ port ${redis_port}
+ bind 127.0.0.1 ::1
+ ${extra_conf}
+ EOF
+
+ # Run the tests
+ distutils-r1_src_test
+
+ # Clean up afterwards
+ kill "$(<"${redis_pid}")" || die
+}