summaryrefslogtreecommitdiff
path: root/dev-python/redis
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/redis')
-rw-r--r--dev-python/redis/Manifest6
-rw-r--r--dev-python/redis/redis-5.0.8.ebuild107
-rw-r--r--dev-python/redis/redis-5.1.0.ebuild107
-rw-r--r--dev-python/redis/redis-5.1.1.ebuild2
4 files changed, 2 insertions, 220 deletions
diff --git a/dev-python/redis/Manifest b/dev-python/redis/Manifest
index bfcbb624de79..e7efe44fd75d 100644
--- a/dev-python/redis/Manifest
+++ b/dev-python/redis/Manifest
@@ -1,7 +1,3 @@
-DIST redis-py-5.0.8.gh.tar.gz 4796278 BLAKE2B 43649156956d5f92598d9191ff3138af4981d957fadbaefa3c2759f8286b12cfcd393fde7c70b7d46600251c8083216d368b9946a0af8915f85e75b4ce736c60 SHA512 cd02a0632156fe134d3425ce41be1f907f8602d5b51e3f1565f158ecd70ba72cd33919508b5d87ca279ad264641504a6981b5bfe615d29db3c4204765c61803e
-DIST redis-py-5.1.0.gh.tar.gz 4829762 BLAKE2B fe2653efdb6479ceae5d7c2d139da23d58106e91de663541e2235b2c82b40cdadc2c12310d9781edb04cb0ff00f0a52f60ac657738bd1b85192f4dc0e2a86289 SHA512 e6209052cd55652fadcc2db2f5bde8d20ad269e132abfb16e0d4184d36fd5573ea728298c999a41cf41ede8b2fe43faeec7392299cb75daddc70fb3fac8a9d68
DIST redis-py-5.1.1.gh.tar.gz 4829819 BLAKE2B 2cf104142c70cb7b082178d26dfd84c9970488613551c2f87052e2f56f2bd1e816f4760dc2070dc8520098768263f810a524278ca6d24e0a97340d94434f97bb SHA512 2dbc5ba3138ca6b00c89185fa7b0280958eb66e3640c30ffe88bb77ef0cc88ae82f11e1d3d2cf94a2e8ef35ce30df3e5dd46ccb02d663a6acdb45085f3f1bc95
-EBUILD redis-5.0.8.ebuild 3041 BLAKE2B dea0539c85ab788f5e97acb9e41fea0610e491c425ca23dca07670b1303a10c3d2aecb35a1ea1464ed6a4004051ab3f157de338343e08bf75460b8131ac80608 SHA512 7eab3332bd2a12795761d7e25b9af9dcaa6e62e23f83405b2455b98d3421b0e4daa948be16c94d89af1a443f537a510f5f8ecdfdc7773541819f5dfe842fb31e
-EBUILD redis-5.1.0.ebuild 3047 BLAKE2B 7fcb7d959fa13cb7417eeaa46a81ae1a784efe2d59a31ad50271b98b7821e998c78458fdf1480155741d99c4a699520fea98db4e1515e6db5e8fb80cbb852a7a SHA512 3a7472b2d4c91b25242b2ee1a64fd577e7c16289b5f894734d5f9fd8918b900f035039a8177b9616281754a73abe12792c58b2e2c2617523f065092974249fc3
-EBUILD redis-5.1.1.ebuild 3047 BLAKE2B 7fcb7d959fa13cb7417eeaa46a81ae1a784efe2d59a31ad50271b98b7821e998c78458fdf1480155741d99c4a699520fea98db4e1515e6db5e8fb80cbb852a7a SHA512 3a7472b2d4c91b25242b2ee1a64fd577e7c16289b5f894734d5f9fd8918b900f035039a8177b9616281754a73abe12792c58b2e2c2617523f065092974249fc3
+EBUILD redis-5.1.1.ebuild 3041 BLAKE2B dea0539c85ab788f5e97acb9e41fea0610e491c425ca23dca07670b1303a10c3d2aecb35a1ea1464ed6a4004051ab3f157de338343e08bf75460b8131ac80608 SHA512 7eab3332bd2a12795761d7e25b9af9dcaa6e62e23f83405b2455b98d3421b0e4daa948be16c94d89af1a443f537a510f5f8ecdfdc7773541819f5dfe842fb31e
MISC metadata.xml 506 BLAKE2B 0e5747e826132dd365bdf6d3a63f0936ed476bc69c4c4d55126e692039046f51f69b193ead0baa181090b11f69ab2a49220d8f906f9fe3fc18331b76ff9e0b0f SHA512 725d650bfe345b132588930a18ade44182ec07f6697d2fd8806dc208ab1556939926e8899fc6d43691101d971f9c1e011fb8a5675fdde4698dbf4c230db15c75
diff --git a/dev-python/redis/redis-5.0.8.ebuild b/dev-python/redis/redis-5.0.8.ebuild
deleted file mode 100644
index 6eb8d8c10f3b..000000000000
--- a/dev-python/redis/redis-5.0.8.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..13} pypy3 )
-
-inherit distutils-r1
-
-MY_P=redis-py-${PV}
-DESCRIPTION="Python client for Redis key-value store"
-HOMEPAGE="
- https://github.com/redis/redis-py/
- https://pypi.org/project/redis/
-"
-SRC_URI="
- https://github.com/redis/redis-py/archive/v${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~riscv ~sparc x86"
-
-RDEPEND="
- $(python_gen_cond_dep '
- >=dev-python/async-timeout-4.0.2[${PYTHON_USEDEP}]
- ' 3.10)
-"
-BDEPEND="
- test? (
- dev-db/redis
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- distutils-r1_src_prepare
-
- # https://github.com/redis/redis-py/issues/3339
- sed -i 's:(forbid_global_loop=True)::' tests/test_asyncio/*.py || die
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # Flaky test
- tests/test_pubsub.py::TestPubSubDeadlock::test_pubsub_deadlock
- # require extra redis modules that apparently aren't packaged
- # on Gentoo
- tests/{,test_asyncio/}test_bloom.py
- tests/{,test_asyncio/}test_graph.py
- tests/{,test_asyncio/}test_json.py
- tests/{,test_asyncio/}test_timeseries.py
- # apparently available only in "Redis Stack 7.2 RC3 or later"
- tests/test_commands.py::TestRedisCommands::test_tfunction_load_delete
- tests/test_commands.py::TestRedisCommands::test_tfunction_list
- tests/test_commands.py::TestRedisCommands::test_tfcall
- # TODO
- tests/test_commands.py::TestRedisCommands::test_module
- tests/test_commands.py::TestRedisCommands::test_module_loadex
- tests/test_commands.py::TestRedisCommands::test_zrank_withscore
- tests/test_commands.py::TestRedisCommands::test_zrevrank_withscore
- tests/test_commands.py::TestRedisCommands::test_xinfo_consumers
- tests/test_asyncio/test_commands.py::TestRedisCommands::test_zrank_withscore
- tests/test_asyncio/test_commands.py::TestRedisCommands::test_zrevrank_withscore
- tests/test_asyncio/test_commands.py::TestRedisCommands::test_xinfo_consumers
- tests/test_asyncio/test_pubsub.py::TestPubSubAutoReconnect::test_reconnect_socket_error[pool-hiredis-listen]
- )
-
- # TODO: try to run more servers?
- epytest -m "not redismod and not onlycluster and not replica and not ssl"
-}
-
-src_test() {
- local redis_pid="${T}"/redis.pid
- local redis_port=6379
-
- if has_version ">=dev-db/redis-7"; then
- local extra_conf="
- enable-debug-command yes
- enable-module-command yes
- "
- fi
-
- # Spawn Redis itself for testing purposes
- einfo "Spawning Redis"
- einfo "NOTE: Port ${redis_port} must be free"
- "${EPREFIX}"/usr/sbin/redis-server - <<- EOF || die "Unable to start redis server"
- daemonize yes
- pidfile ${redis_pid}
- port ${redis_port}
- bind 127.0.0.1 ::1
- ${extra_conf}
- EOF
-
- # Run the tests
- distutils-r1_src_test
-
- # Clean up afterwards
- kill "$(<"${redis_pid}")" || die
-}
diff --git a/dev-python/redis/redis-5.1.0.ebuild b/dev-python/redis/redis-5.1.0.ebuild
deleted file mode 100644
index f0029e3d0af7..000000000000
--- a/dev-python/redis/redis-5.1.0.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..13} pypy3 )
-
-inherit distutils-r1
-
-MY_P=redis-py-${PV}
-DESCRIPTION="Python client for Redis key-value store"
-HOMEPAGE="
- https://github.com/redis/redis-py/
- https://pypi.org/project/redis/
-"
-SRC_URI="
- https://github.com/redis/redis-py/archive/v${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
-
-RDEPEND="
- $(python_gen_cond_dep '
- >=dev-python/async-timeout-4.0.2[${PYTHON_USEDEP}]
- ' 3.10)
-"
-BDEPEND="
- test? (
- dev-db/redis
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- distutils-r1_src_prepare
-
- # https://github.com/redis/redis-py/issues/3339
- sed -i 's:(forbid_global_loop=True)::' tests/test_asyncio/*.py || die
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # Flaky test
- tests/test_pubsub.py::TestPubSubDeadlock::test_pubsub_deadlock
- # require extra redis modules that apparently aren't packaged
- # on Gentoo
- tests/{,test_asyncio/}test_bloom.py
- tests/{,test_asyncio/}test_graph.py
- tests/{,test_asyncio/}test_json.py
- tests/{,test_asyncio/}test_timeseries.py
- # apparently available only in "Redis Stack 7.2 RC3 or later"
- tests/test_commands.py::TestRedisCommands::test_tfunction_load_delete
- tests/test_commands.py::TestRedisCommands::test_tfunction_list
- tests/test_commands.py::TestRedisCommands::test_tfcall
- # TODO
- tests/test_commands.py::TestRedisCommands::test_module
- tests/test_commands.py::TestRedisCommands::test_module_loadex
- tests/test_commands.py::TestRedisCommands::test_zrank_withscore
- tests/test_commands.py::TestRedisCommands::test_zrevrank_withscore
- tests/test_commands.py::TestRedisCommands::test_xinfo_consumers
- tests/test_asyncio/test_commands.py::TestRedisCommands::test_zrank_withscore
- tests/test_asyncio/test_commands.py::TestRedisCommands::test_zrevrank_withscore
- tests/test_asyncio/test_commands.py::TestRedisCommands::test_xinfo_consumers
- tests/test_asyncio/test_pubsub.py::TestPubSubAutoReconnect::test_reconnect_socket_error[pool-hiredis-listen]
- )
-
- # TODO: try to run more servers?
- epytest -m "not redismod and not onlycluster and not replica and not ssl"
-}
-
-src_test() {
- local redis_pid="${T}"/redis.pid
- local redis_port=6379
-
- if has_version ">=dev-db/redis-7"; then
- local extra_conf="
- enable-debug-command yes
- enable-module-command yes
- "
- fi
-
- # Spawn Redis itself for testing purposes
- einfo "Spawning Redis"
- einfo "NOTE: Port ${redis_port} must be free"
- "${EPREFIX}"/usr/sbin/redis-server - <<- EOF || die "Unable to start redis server"
- daemonize yes
- pidfile ${redis_pid}
- port ${redis_port}
- bind 127.0.0.1 ::1
- ${extra_conf}
- EOF
-
- # Run the tests
- distutils-r1_src_test
-
- # Clean up afterwards
- kill "$(<"${redis_pid}")" || die
-}
diff --git a/dev-python/redis/redis-5.1.1.ebuild b/dev-python/redis/redis-5.1.1.ebuild
index f0029e3d0af7..6eb8d8c10f3b 100644
--- a/dev-python/redis/redis-5.1.1.ebuild
+++ b/dev-python/redis/redis-5.1.1.ebuild
@@ -22,7 +22,7 @@ S=${WORKDIR}/${MY_P}
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~riscv ~sparc x86"
RDEPEND="
$(python_gen_cond_dep '