summaryrefslogtreecommitdiff
path: root/dev-python/reflink/reflink-0.2.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/reflink/reflink-0.2.1.ebuild')
-rw-r--r--dev-python/reflink/reflink-0.2.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/reflink/reflink-0.2.1.ebuild b/dev-python/reflink/reflink-0.2.1.ebuild
new file mode 100644
index 000000000000..59c051cb1949
--- /dev/null
+++ b/dev-python/reflink/reflink-0.2.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="RFC-compliant FQDN validation and manipulation for Python"
+HOMEPAGE="https://gitlab.com/rubdos/pyreflink"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ sys-fs/btrfs-progs
+ )
+"
+RDEPEND="virtual/python-cffi[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+# goes places, like writing to /dev or creating btrfs volumes
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}/${PV}-correct-test-deps.patch" )
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
+
+python_test() {
+ esetup.py test
+}