summaryrefslogtreecommitdiff
path: root/dev-python/regions
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/regions')
-rw-r--r--dev-python/regions/Manifest3
-rw-r--r--dev-python/regions/metadata.xml14
-rw-r--r--dev-python/regions/regions-0.2.ebuild58
3 files changed, 0 insertions, 75 deletions
diff --git a/dev-python/regions/Manifest b/dev-python/regions/Manifest
deleted file mode 100644
index 62d955a97f45..000000000000
--- a/dev-python/regions/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST regions-0.2.tar.gz 535230 BLAKE2B ab44e35c6fede23da1116bf20fa65ce0e72daebbfd5effd64434abee510a450e5e2343a63810e8f7ab3a00296b55e8792b1f73777c98418cb942df21c58d7208 SHA512 1970e55a834057ca7d5ea9e29769e71f4287d184f2576cd03ed810df8381517145fb157f2585dadab483312e2d66dca295f7aea10ca5a65367c3a95726331b19
-EBUILD regions-0.2.ebuild 1526 BLAKE2B 7405d9b84bd31234c74bbe340e43f55be719fe1542b778ce75c515cc9a1ef07bd510821f206eca7c165564ea807589f51339ec3e9ce91129c66f76902aa50e42 SHA512 e4aa525da0a54c6853d9de99d5a228ebf79cb0640c64a1c264e99444b2bcd77f8ae8b70ac15daaa21ad49f05ea551bc5f7e9a83c2cadd68dfe41cbbc28252687
-MISC metadata.xml 538 BLAKE2B 7b0f5c066609f5cce6e5415c38f8bc215ef792a18a6ceba55e0e0f2ca3467613cc1e9d6e996c993fb4a1d58eb50aa3ec0d68866e6570b526d9513eb80f68221b SHA512 6a457b10fbc637a3130c8e94bbd441f8030596265864acf1003a314f464c082a49b72d87863ed996d1b80d84c69f88dce1987e48fc413afbc04e2cb949fad41d
diff --git a/dev-python/regions/metadata.xml b/dev-python/regions/metadata.xml
deleted file mode 100644
index 63ff2600215a..000000000000
--- a/dev-python/regions/metadata.xml
+++ /dev/null
@@ -1,14 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>sci-astronomy@gentoo.org</email>
- <name>Gentoo Astronomy Project</name>
-</maintainer>
-<longdescription lang="en">
- The goal is to merge the functionality from pyregion and photutils apertures and then after some time propose this package for inclusion in the Astropy core.
-</longdescription>
-<upstream>
- <remote-id type="pypi">regions</remote-id>
-</upstream>
-</pkgmetadata>
diff --git a/dev-python/regions/regions-0.2.ebuild b/dev-python/regions/regions-0.2.ebuild
deleted file mode 100644
index fde1daf2ab69..000000000000
--- a/dev-python/regions/regions-0.2.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-inherit distutils-r1 virtualx xdg-utils
-
-DESCRIPTION="Astropy affiliated package for region handling"
-HOMEPAGE="http://astropy-regions.readthedocs.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-LICENSE="BSD"
-
-IUSE="doc test"
-RDEPEND="dev-python/astropy[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/astropy-helpers[${PYTHON_USEDEP}]
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
- dev-python/wcsaxes[${PYTHON_USEDEP}] )
- test? (
- dev-python/pytest-mpl[${PYTHON_USEDEP}]
- dev-python/pytest-arraydiff[${PYTHON_USEDEP}]
- dev-python/wcsaxes[${PYTHON_USEDEP}]
- sci-libs/scipy[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- # use astropy-helpers from system
- sed -i -e '/auto_use/s/True/False/' setup.cfg || die
- xdg_environment_reset
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- python_setup
- VARTEXFONTS="${T}"/fonts \
- MPLCONFIGDIR="${BUILD_DIR}" \
- PYTHONPATH="${BUILD_DIR}"/lib \
- esetup.py build_sphinx --no-intersphinx
- fi
-}
-
-python_test() {
- echo 'backend: Agg' > ${WORKDIR}/matplotlibrc || die
- export MATPLOTLIBRC=${WORKDIR}
- virtx esetup.py test
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}