summaryrefslogtreecommitdiff
path: root/dev-python/repoze-sphinx-autointerface
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/repoze-sphinx-autointerface')
-rw-r--r--dev-python/repoze-sphinx-autointerface/Manifest4
-rw-r--r--dev-python/repoze-sphinx-autointerface/metadata.xml1
-rw-r--r--dev-python/repoze-sphinx-autointerface/repoze-sphinx-autointerface-0.8.ebuild11
3 files changed, 6 insertions, 10 deletions
diff --git a/dev-python/repoze-sphinx-autointerface/Manifest b/dev-python/repoze-sphinx-autointerface/Manifest
index a54a1dc0e58c..f17ba470e43d 100644
--- a/dev-python/repoze-sphinx-autointerface/Manifest
+++ b/dev-python/repoze-sphinx-autointerface/Manifest
@@ -1,3 +1,3 @@
DIST repoze.sphinx.autointerface-0.8.tar.gz 8987 BLAKE2B aeeaf23f18394eae8ff817e7f4838a332d34e3c7717a67bf123c02a6bd7b6122d727a0120922b0471d6d6d7a1b2312058373a2498150b36446edc049a178773d SHA512 40aa3401a5f542329dbce6b8b27fad0b94d3077ac9a0e01cf2f1f43da5bcb9202eb76eaaa8b1b81edf51a391ebe32eefde59afab1673d86b412995185a4866f3
-EBUILD repoze-sphinx-autointerface-0.8.ebuild 967 BLAKE2B 2b5a24455a20fe7dbf56e585a239bb138c982c972fdcdb244c306cfa1b874e3b22799d257ce3992bffdab5664acabdf26e8daef98c273e59768da99d8d3897fb SHA512 a0b7539da1b251f249613aa28a9bd11cfc0c3c7e0b9c27468d5cbf57245d9260e3ee0dbf2e8f84e4791af3eb8d537c33084c927e0199932adeafc83c8ae0e73d
-MISC metadata.xml 335 BLAKE2B 6935bfb58617ad78e5f0aaf3febaf7a629c0470cc667685662f3434a34c40568f63f89cb49e6802753475a665ab13caa56e6d726fa5a34f070ed409bb403841c SHA512 689a11f848984c58defc523d400a834c228adab649c1f0d197752696bb73a5962053c55b3938bbdaca94da6a063d7dfa853898c0d51222d5cddd3911809bc3cf
+EBUILD repoze-sphinx-autointerface-0.8.ebuild 944 BLAKE2B 53608d69ce1e2d7368a257746f10d986aca19f6f61f0a3e398330171801bfe308c342a60705b89aadfbfafdeea71fa0118bfd055b978bbee49d615f69e7dbc78 SHA512 1f054737ffdfc0b1825683b115261594e1740f70d3e0b72d6bcd29de8d8fa3de51869223451c1676194ce9e843822431d3b65f75cae8bd4f44d3b72c0b8c24c3
+MISC metadata.xml 359 BLAKE2B 24e7252204ae97a034ae7a805418cc3cb47c2c5c72069bf84e7c79a51a88aceb0d35dca02737f8ef10c6be3db706efdb8a5582319559908a28b025ec82dcc433 SHA512 8ccf9ba202d2be2362ab1c5267f6bab846285ab8580908769c5f4f14d53dd1cff3ec71f91e8a543c68433f0b63910ee1f379c91281508cfa4ce91b1a4531b5ba
diff --git a/dev-python/repoze-sphinx-autointerface/metadata.xml b/dev-python/repoze-sphinx-autointerface/metadata.xml
index b517394095ba..c1b6514bacd8 100644
--- a/dev-python/repoze-sphinx-autointerface/metadata.xml
+++ b/dev-python/repoze-sphinx-autointerface/metadata.xml
@@ -5,6 +5,7 @@
<email>dolsen@gentoo.org</email>
<name>Brian Dolbec</name>
</maintainer>
+ <stabilize-allarches/>
<upstream>
<remote-id type="pypi">repoze.sphinx.autointerface</remote-id>
</upstream>
diff --git a/dev-python/repoze-sphinx-autointerface/repoze-sphinx-autointerface-0.8.ebuild b/dev-python/repoze-sphinx-autointerface/repoze-sphinx-autointerface-0.8.ebuild
index a8135be13fff..519d2a62939c 100644
--- a/dev-python/repoze-sphinx-autointerface/repoze-sphinx-autointerface-0.8.ebuild
+++ b/dev-python/repoze-sphinx-autointerface/repoze-sphinx-autointerface-0.8.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_USE_SETUPTOOLS=rdepend
-
inherit distutils-r1
MY_PN=${PN//-/.}
@@ -14,6 +13,7 @@ MY_P=${MY_PN}-${PV}
DESCRIPTION="Sphinx extension: auto-generates API docs from Zope interfaces"
HOMEPAGE="https://pypi.org/project/repoze.sphinx.autointerface/"
SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="repoze"
SLOT="0"
@@ -24,11 +24,6 @@ RDEPEND="
dev-python/sphinx[${PYTHON_USEDEP}]
dev-python/zope-interface[${PYTHON_USEDEP}]
"
-DEPEND="
- ${RDEPEND}
-"
-
-S=${WORKDIR}/${MY_P}
python_install() {
distutils-r1_python_install