summaryrefslogtreecommitdiff
path: root/dev-python/requestsexceptions/requestsexceptions-1.1.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/requestsexceptions/requestsexceptions-1.1.3.ebuild')
-rw-r--r--dev-python/requestsexceptions/requestsexceptions-1.1.3.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/requestsexceptions/requestsexceptions-1.1.3.ebuild b/dev-python/requestsexceptions/requestsexceptions-1.1.3.ebuild
new file mode 100644
index 000000000000..0260b7f92a9d
--- /dev/null
+++ b/dev-python/requestsexceptions/requestsexceptions-1.1.3.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Finds the correct path to exceptions in the requests library."
+HOMEPAGE="https://github.com/openstack-infra/requestsexceptions"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-0.11[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}"