summaryrefslogtreecommitdiff
path: root/dev-python/rply/rply-0.7.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/rply/rply-0.7.6.ebuild')
-rw-r--r--dev-python/rply/rply-0.7.6.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/rply/rply-0.7.6.ebuild b/dev-python/rply/rply-0.7.6.ebuild
deleted file mode 100644
index 3499bd15290c..000000000000
--- a/dev-python/rply/rply-0.7.6.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_5,3_6} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="Pure python parser generator that also works with RPython"
-HOMEPAGE="https://github.com/alex/rply"
-SRC_URI="https://github.com/alex/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/appdirs[${PYTHON_USEDEP}]
- test? (
- dev-python/py[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}] )"
-
-python_prepare() {
- # https://github.com/alex/rply/issues/26; fail under py[3-4]
- if python_is_python3; then
- sed -e s':test_simple:_&:' -e s':test_empty_production:_&:' \
- -i tests/test_parsergenerator.py || die
- fi
-}
-
-python_test() {
- pytest -vv || die "Tests fail with ${EPYTHON}"
-}