summaryrefslogtreecommitdiff
path: root/dev-python/rpyc
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/rpyc')
-rw-r--r--dev-python/rpyc/Manifest2
-rw-r--r--dev-python/rpyc/rpyc-5.2.3.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/rpyc/Manifest b/dev-python/rpyc/Manifest
index 8c584005052a..9184338f004d 100644
--- a/dev-python/rpyc/Manifest
+++ b/dev-python/rpyc/Manifest
@@ -1,3 +1,5 @@
DIST rpyc-5.1.0.tar.gz 1260651 BLAKE2B 4be17e5de4b0475cd63b99bf20e55e3221149f974b9efec638e0387d71815a5a2e4ea782578152690e019e7b8a4ece17405eed6626578a9c9e379d0f4b589008 SHA512 e9783392f423abca6b488dff5be36dae066980004bd221ca5a1c451f0f9dc7e1daf749650106802f9159de619a8d5e2cd6dc90e9a5f49d16f01bbedd59b504cf
+DIST rpyc-5.2.3.tar.gz 1267934 BLAKE2B 3c03d587293375f875de31d6a89ba07b47bd4f4ff9fd5c7b23ed0c83e420e9d2bab08844c3538299797203ac90e7e81b955db02de70bf1cee5ea59d8475a6848 SHA512 4be189a719be100886e08d9c2c0769d12b7d1c5e167c197ebee1a3db542e228f2124fea976e5af3680136b298ce4632c79b2f302128dff31ebf45dcf52a9743f
EBUILD rpyc-5.1.0.ebuild 1741 BLAKE2B aff12ad540be96c4cc71c5cdf2d0f4c8494d6a41757a9e57e0e5ef0030768f0829d8c088611178ffa244d3f6ec6ce2db1b46c0092d3b7e4154a40ac1e44d654a SHA512 b84c7a5cb1e053a8fcb2722b7d66ebff5d4e9030462b2ab078301549c5a037360120dfebab6cb0c453f6efd7fb2a2e37bd47e6f97a04e3e7b023f6a174d9d325
+EBUILD rpyc-5.2.3.ebuild 1774 BLAKE2B 787218825fce9fa0f9740333c30adb975fde0ecd20ae3e5e48f10d5a8119c1c87fe8807abe980af27ec9ffefc02b46b36c1242467214b7b18fabccc3866e743c SHA512 520219c1f37b09cc7df8148afb4f67b0566d4f56452d30d4e2385ed6e5ebeb310af4bbdad340bd9d80715a5addcb1e101191bf1694d4bfabc215360b3140c795
MISC metadata.xml 654 BLAKE2B f84ea5b5fb66c2661bdcbed8566a77c872b6f1b3a6b0cb021269657b21fd414e70edf03f205ee2038d9d83a20e25d32b15760d915b98066aa7fe1a4cfeb3bd16 SHA512 6ea40af97501443c8d4ae783137bb9547c5a4cc3685c01b9d684691d110f67eb43056acfcebcc510c06fc40ff596ad9e3e30cf76cb07807f23250721e93b4954
diff --git a/dev-python/rpyc/rpyc-5.2.3.ebuild b/dev-python/rpyc/rpyc-5.2.3.ebuild
new file mode 100644
index 000000000000..0f85434abd00
--- /dev/null
+++ b/dev-python/rpyc/rpyc-5.2.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Remote Python Call (RPyC), a transparent and symmetric RPC library"
+HOMEPAGE="https://rpyc.readthedocs.io/en/latest/
+ https://pypi.org/project/rpyc/
+ https://github.com/tomerfiliba-org/rpyc"
+SRC_URI="https://github.com/tomerfiliba-org/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# USE flags gdb, numpy are used *only* to run tests depending on these packages
+IUSE="test numpy gdb"
+RESTRICT="!test? ( test )"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ numpy? ( dev-python/numpy[${PYTHON_USEDEP}] dev-python/pandas[${PYTHON_USEDEP}] )
+ gdb? ( sys-devel/gdb )"
+
+RDEPEND="dev-python/plumbum[${PYTHON_USEDEP}]
+ dev-python/gevent[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ default
+
+ # Windows specific test
+ rm tests/test_win32pipes.py || die "rm tests/test_win32pipes.py failed"
+
+ # These tests require running sshd
+ rm tests/test_ssh.py tests/test_deploy.py || die "rm test_ssh.py test_deploy.py failed"
+
+ # This test requires internet access
+ rm tests/test_registry.py || die "rm test_registry.py failed"
+
+ # This test fails with NO_CIPHERS_AVAILABLE
+ rm tests/test_ssl.py || die "rm test_ssl.py failed"
+
+ if ! use numpy
+ then rm tests/test_service_pickle.py || die "rm test_service_pickle.py failed"
+ fi
+
+ if ! use gdb
+ then rm tests/test_gdb.py || die "rm test_gdb.py failed"
+ fi
+}
+
+python_test() {
+ # for some reason, when tests are run via pytest or nose, some of them hung
+ pushd tests > /dev/null || die "pushd tests failed"
+ for x in test_*.py
+ do ${PYTHON} ${x} || die "${x} failed"
+ done
+ popd > /dev/null
+}