summaryrefslogtreecommitdiff
path: root/dev-python/rpyc
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/rpyc')
-rw-r--r--dev-python/rpyc/Manifest4
-rw-r--r--dev-python/rpyc/rpyc-5.3.1-r1.ebuild69
-rw-r--r--dev-python/rpyc/rpyc-6.0.0.ebuild2
3 files changed, 2 insertions, 73 deletions
diff --git a/dev-python/rpyc/Manifest b/dev-python/rpyc/Manifest
index 30e0ef560799..d76cc3832a46 100644
--- a/dev-python/rpyc/Manifest
+++ b/dev-python/rpyc/Manifest
@@ -1,6 +1,4 @@
AUX rpyc-5.3.0-no-gevent.patch 1241 BLAKE2B 44b0584b90aa4730998dd9c44430edbb0348f581b930ce1663b4dc7105c6fafccd1d73c2850892ec7898f678bc57de592dcec1af4615778919b97a15fc9d56ca SHA512 d057255548f94c433d2e6f064d9db33caf7909ae17a9eddaabb2f87560f31a6b9e94c0470b78fab7aca15c6c96b6a8c2cf96d92d57d9925d5616c7454f823326
-DIST rpyc-5.3.1.gh.tar.gz 1271046 BLAKE2B b7c86aa5cf774d306b2d6fdbac97441533bc5a847aaf03c11b0abf0a07587a2f7d081470d3402fde4251ea6654051d96983feefa2ba7e65a9a95d76f179edcad SHA512 a328903c336483f7110cbbff96173ba0b5ae6cf16f6306c624055bd631d914772c42dcfcf48a275b7dc53241f6b10a397ee49f17b8a3c3c8dbee8f42ac784465
DIST rpyc-6.0.0.gh.tar.gz 1273858 BLAKE2B e55d008dc772be7fd4bae9065a5eabcf5612faf8131e8161e7921eeb84475183c677687ef8606c664003089ae714d4cb403ff6afa26d2695a8fe763d549aab0d SHA512 04b74fa6d4ad944b43c3f3acb6c9029a826da350bffdc59875ec31562bbaa70945e74bedb69778811ce16560ef4f4cfe2579b9c6b52773fe238951fc6328e029
-EBUILD rpyc-5.3.1-r1.ebuild 2049 BLAKE2B ef1c52d37ad4e279f8c0ba8b090c357c5a684466a9838c97b3d65c8581d17608344301249a03a52b8d0d28ea8051828f2bde03d3571c57c4130fa6d36d114989 SHA512 29a52631f1f6fa93006d06663bc6091b29d5e90455b9c999fb6b748ae5d233a79be1fdb688ef0a2623674742a8c722067a5f952757df901b33186c2d3e3cda32
-EBUILD rpyc-6.0.0.ebuild 2052 BLAKE2B 4f97b537dea39d0fa9723b935e11768f409e9df711627e677c7fc8c29b11cc2319d315c0a3c04e336f79b6ba4c51ec209ab521439d63415ea4feaf3535521e5b SHA512 c8e9b37aa39f091365937da827b10082e54e3ff837ee884fe793f80738e7094c638a14e53fc1ebcca4b6ba22e2b077b38560fbc4ad2cabcee33f4358247d5718
+EBUILD rpyc-6.0.0.ebuild 2049 BLAKE2B ef1c52d37ad4e279f8c0ba8b090c357c5a684466a9838c97b3d65c8581d17608344301249a03a52b8d0d28ea8051828f2bde03d3571c57c4130fa6d36d114989 SHA512 29a52631f1f6fa93006d06663bc6091b29d5e90455b9c999fb6b748ae5d233a79be1fdb688ef0a2623674742a8c722067a5f952757df901b33186c2d3e3cda32
MISC metadata.xml 654 BLAKE2B 9fa48ba4c923e8a9ca25fcc8a117d19a268bdd33da4ba819e9368c1b098782163ba87763906db232dda7f39e56eb1e5389970b7d01dd41975e9480e5a364c8ee SHA512 e09b18c5214812df6fe48e663e2e9fa796fbeb213994513b0733df6016ef7ee6132681d923824c3ccb80d3863b27ed53fce3f4e46093bab10a51b09db7b79a65
diff --git a/dev-python/rpyc/rpyc-5.3.1-r1.ebuild b/dev-python/rpyc/rpyc-5.3.1-r1.ebuild
deleted file mode 100644
index 7c6af49decaf..000000000000
--- a/dev-python/rpyc/rpyc-5.3.1-r1.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="Remote Python Call (RPyC), a transparent and symmetric RPC library"
-HOMEPAGE="https://rpyc.readthedocs.io/en/latest/
- https://pypi.org/project/rpyc/
- https://github.com/tomerfiliba-org/rpyc"
-SRC_URI="https://github.com/tomerfiliba-org/rpyc/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm64 ~riscv x86"
-
-# USE flags gdb, numpy are used *only* to run tests depending on these packages
-IUSE="test numpy gdb"
-RESTRICT="!test? ( test )"
-
-CDEPEND="numpy? ( dev-python/numpy[${PYTHON_USEDEP}] dev-python/pandas[${PYTHON_USEDEP}] )
- gdb? ( dev-debug/gdb )"
-
-DEPEND="${CDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-RDEPEND="${CDEPEND}
- dev-python/plumbum[${PYTHON_USEDEP}]"
-
-PATCHES=( "${FILESDIR}"/${PN}-5.3.0-no-gevent.patch )
-
-src_prepare() {
- default
-
- # Windows specific test
- rm tests/test_win32pipes.py || die "rm tests/test_win32pipes.py failed"
-
- # These tests require running sshd
- rm tests/test_ssh.py tests/test_deploy.py || die "rm test_ssh.py test_deploy.py failed"
-
- # This test requires internet access
- rm tests/test_registry.py || die "rm test_registry.py failed"
-
- # This test fails with NO_CIPHERS_AVAILABLE
- rm tests/test_ssl.py || die "rm test_ssl.py failed"
-
- # dev-python/gevent is being removed
- rm tests/test_gevent_server.py || die "rm test_gevent_server.py failed"
-
- if ! use numpy
- then rm tests/test_service_pickle.py || die "rm test_service_pickle.py failed"
- fi
-
- if ! use gdb
- then rm tests/test_gdb.py || die "rm test_gdb.py failed"
- fi
-}
-
-python_test() {
- # for some reason, when tests are run via pytest or nose, some of them hung
- pushd tests > /dev/null || die "pushd tests failed"
- for x in test_*.py
- do PYTHONPATH="${WORKDIR}"/${P}-${EPYTHON/./_}/install/usr/lib/${EPYTHON}/site-packages ${EPYTHON} ${x} || die "${x} failed"
- done
- popd > /dev/null
-}
diff --git a/dev-python/rpyc/rpyc-6.0.0.ebuild b/dev-python/rpyc/rpyc-6.0.0.ebuild
index ba28161bff98..7c6af49decaf 100644
--- a/dev-python/rpyc/rpyc-6.0.0.ebuild
+++ b/dev-python/rpyc/rpyc-6.0.0.ebuild
@@ -15,7 +15,7 @@ SRC_URI="https://github.com/tomerfiliba-org/rpyc/archive/refs/tags/${PV}.tar.gz
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+KEYWORDS="amd64 arm64 ~riscv x86"
# USE flags gdb, numpy are used *only* to run tests depending on these packages
IUSE="test numpy gdb"