summaryrefslogtreecommitdiff
path: root/dev-python/s3fs/s3fs-0.1.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/s3fs/s3fs-0.1.5.ebuild')
-rw-r--r--dev-python/s3fs/s3fs-0.1.5.ebuild32
1 files changed, 0 insertions, 32 deletions
diff --git a/dev-python/s3fs/s3fs-0.1.5.ebuild b/dev-python/s3fs/s3fs-0.1.5.ebuild
deleted file mode 100644
index 67bad6d489d7..000000000000
--- a/dev-python/s3fs/s3fs-0.1.5.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Pythonic file interface to S3"
-HOMEPAGE="https://s3fs.readthedocs.io/en/latest/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/boto3[${PYTHON_USEDEP}]"
-
-DEPEND="
- ${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/moto[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )"
-
-python_test() {
- py.test -v || die
-}