summaryrefslogtreecommitdiff
path: root/dev-python/scikit-build-core
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/scikit-build-core')
-rw-r--r--dev-python/scikit-build-core/Manifest2
-rw-r--r--dev-python/scikit-build-core/scikit-build-core-0.8.1.ebuild54
2 files changed, 0 insertions, 56 deletions
diff --git a/dev-python/scikit-build-core/Manifest b/dev-python/scikit-build-core/Manifest
index 3ab20e1c919a..85182ab100d8 100644
--- a/dev-python/scikit-build-core/Manifest
+++ b/dev-python/scikit-build-core/Manifest
@@ -1,5 +1,3 @@
-DIST scikit_build_core-0.8.1.tar.gz 202391 BLAKE2B acfa3d2c235ac1837b52e96a3b3a04329f9c4a1cb89ed6f56dc1596d67e5881f5a2950bb3b55e038f2b958579cb3824fc379af310ca9c1ae4dc90f16cb1c1834 SHA512 a343391178456af740e527002187161f83dbe94d1802fc8bd0e1370739367e351709449686a6fe5cfca24dd445f39f3dcafa8762a9a5f2e845d5c2a22e2534da
DIST scikit_build_core-0.8.2.tar.gz 203630 BLAKE2B 7093fd02891fe225ffee1b6da7800e49eb71c6468947fff1a80015eda8c9940f117196dfd067d0ea274d9958f8f13681ccd859f95ce9bf6a7d72eedc367489f3 SHA512 4b33936912806b5f607492d253d5cc6b2523d4892043caad82fed76140e53a0e9dec8178811a618cdc9b64f247e37145d474eb1979d181dd595b4905def1da8f
-EBUILD scikit-build-core-0.8.1.ebuild 1455 BLAKE2B de01bed5cf6c16abb5fa9eb55a5f0b0056e79ea2181bb85bdff0f4b507229443332e0b01233e110f08bf4c3a9eb9c89989e92bffda64f2809803c495a57f6776 SHA512 9240195ba041e55a52f04072e0c0930c7cb606479a5453a67267ac3b3ac41151f42c2248e596a08017668404cb6e737d7e514e83294cc5b6a97be1fd3faa7172
EBUILD scikit-build-core-0.8.2.ebuild 1455 BLAKE2B de01bed5cf6c16abb5fa9eb55a5f0b0056e79ea2181bb85bdff0f4b507229443332e0b01233e110f08bf4c3a9eb9c89989e92bffda64f2809803c495a57f6776 SHA512 9240195ba041e55a52f04072e0c0930c7cb606479a5453a67267ac3b3ac41151f42c2248e596a08017668404cb6e737d7e514e83294cc5b6a97be1fd3faa7172
MISC metadata.xml 393 BLAKE2B 25bdc0bc295ed4bd7cd76a5a6952cb7fa5d5a404d3260562f2ed322d80f2466add0373a2a6b10a41c4dc2211e82e0a680735301d8844e70a54760301b4ab190f SHA512 176537f2027aedb3bc8bd16bbbcde8bfed246d621763e22a979f2942c016e1bafa5ef2d11d8d078e5d59970ea115864a8501185343bc3d4b9fd8493adbd16aab
diff --git a/dev-python/scikit-build-core/scikit-build-core-0.8.1.ebuild b/dev-python/scikit-build-core/scikit-build-core-0.8.1.ebuild
deleted file mode 100644
index d49a764ca1e3..000000000000
--- a/dev-python/scikit-build-core/scikit-build-core-0.8.1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 2023-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Build backend for CMake based projects"
-HOMEPAGE="
- https://github.com/scikit-build/scikit-build-core/
- https://pypi.org/project/scikit-build-core/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-# we always want [pyproject] extra
-RDEPEND="
- >=dev-python/packaging-20.9[${PYTHON_USEDEP}]
- >=dev-python/pathspec-0.10.1[${PYTHON_USEDEP}]
- >=dev-python/pyproject-metadata-0.5[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/exceptiongroup[${PYTHON_USEDEP}]
- >=dev-python/tomli-1.1[${PYTHON_USEDEP}]
- ' 3.9 3.10)
-"
-BDEPEND="
- dev-python/hatch-vcs[${PYTHON_USEDEP}]
- test? (
- dev-python/build[${PYTHON_USEDEP}]
- >=dev-python/cattrs-22.2.0[${PYTHON_USEDEP}]
- dev-python/pybind11[${PYTHON_USEDEP}]
- >=dev-python/pytest-subprocess-1.5[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/virtualenv[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # TODO / we don't package validate_pyproject anyway
- tests/test_schema.py::test_compare_schemas
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -p subprocess -m "not isolated and not network"
-}