summaryrefslogtreecommitdiff
path: root/dev-python/scrypt/scrypt-0.8.13-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/scrypt/scrypt-0.8.13-r2.ebuild')
-rw-r--r--dev-python/scrypt/scrypt-0.8.13-r2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/scrypt/scrypt-0.8.13-r2.ebuild b/dev-python/scrypt/scrypt-0.8.13-r2.ebuild
new file mode 100644
index 000000000000..5f0529ec3951
--- /dev/null
+++ b/dev-python/scrypt/scrypt-0.8.13-r2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7,8}} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Bindings for the scrypt key derivation function library"
+HOMEPAGE="https://bitbucket.org/mhallin/py-scrypt/wiki/Home/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~sparc ~x86"
+SLOT="0"
+IUSE="test doc"
+
+RDEPEND="dev-libs/openssl:0="
+DEPEND="${RDEPEND}"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest