summaryrefslogtreecommitdiff
path: root/dev-python/seaborn/seaborn-0.11.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/seaborn/seaborn-0.11.2.ebuild')
-rw-r--r--dev-python/seaborn/seaborn-0.11.2.ebuild25
1 files changed, 23 insertions, 2 deletions
diff --git a/dev-python/seaborn/seaborn-0.11.2.ebuild b/dev-python/seaborn/seaborn-0.11.2.ebuild
index 16a604584049..50b1cabf1626 100644
--- a/dev-python/seaborn/seaborn-0.11.2.ebuild
+++ b/dev-python/seaborn/seaborn-0.11.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -12,7 +12,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="amd64 ~x86 ~amd64-linux ~x86-linux"
RDEPEND="
dev-python/matplotlib[${PYTHON_USEDEP}]
@@ -23,9 +23,30 @@ RDEPEND="
"
BDEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+PATCHES=(
+ "${FILESDIR}"/${PN}-Update-tests-for-compatability-with-matplotlib-3.5.0.patch
+)
+
distutils_enable_tests pytest
python_test() {
+ # Tests fail due to a newer matplotlib (3.5) being used. Was fixed
+ # upstream in https://github.com/mwaskom/seaborn/issues/2663 but not
+ # for the 0.11 branch. Partially backported in
+ # seaborn-Update-tests-for-compatability-with-matplotlib-3.5.0.patch.
+ local EPYTEST_DESELECT=(
+ 'seaborn/tests/test_categorical.py::TestBoxPlotter::test_axes_data'
+ 'seaborn/tests/test_categorical.py::TestBoxPlotter::test_box_colors'
+ 'seaborn/tests/test_categorical.py::TestBoxPlotter::test_draw_missing_boxes'
+ 'seaborn/tests/test_categorical.py::TestBoxPlotter::test_missing_data'
+ 'seaborn/tests/test_categorical.py::TestCatPlot::test_plot_elements'
+ 'seaborn/tests/test_categorical.py::TestBoxenPlotter::test_box_colors'
+ 'seaborn/tests/test_distributions.py::TestKDEPlotUnivariate::test_legend'
+ 'seaborn/tests/test_distributions.py::TestKDEPlotBivariate::test_fill_artists'
+ 'seaborn/tests/test_distributions.py::TestDisPlot::test_with_rug[kwargs0]'
+ 'seaborn/tests/test_distributions.py::TestDisPlot::test_with_rug[kwargs1]'
+ 'seaborn/tests/test_distributions.py::TestDisPlot::test_with_rug[kwargs2]'
+ )
cat > matplotlibrc <<- EOF || die
backend : Agg
EOF