summaryrefslogtreecommitdiff
path: root/dev-python/semver/semver-3.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/semver/semver-3.0.0.ebuild')
-rw-r--r--dev-python/semver/semver-3.0.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/semver/semver-3.0.0.ebuild b/dev-python/semver/semver-3.0.0.ebuild
new file mode 100644
index 000000000000..bf44d18fbd00
--- /dev/null
+++ b/dev-python/semver/semver-3.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Python module for semantic versioning"
+HOMEPAGE="
+ https://github.com/python-semver/python-semver/
+ https://pypi.org/project/semver/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -o addopts=
+}