summaryrefslogtreecommitdiff
path: root/dev-python/send2trash/send2trash-1.8.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/send2trash/send2trash-1.8.2.ebuild')
-rw-r--r--dev-python/send2trash/send2trash-1.8.2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/send2trash/send2trash-1.8.2.ebuild b/dev-python/send2trash/send2trash-1.8.2.ebuild
new file mode 100644
index 000000000000..fd7d2c7a4f0c
--- /dev/null
+++ b/dev-python/send2trash/send2trash-1.8.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=Send2Trash
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sends files to the Trash (or Recycle Bin)"
+HOMEPAGE="
+ https://github.com/arsenetar/send2trash/
+ https://pypi.org/project/Send2Trash/
+"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest