summaryrefslogtreecommitdiff
path: root/dev-python/sentinels/sentinels-1.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sentinels/sentinels-1.0.0.ebuild')
-rw-r--r--dev-python/sentinels/sentinels-1.0.0.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-python/sentinels/sentinels-1.0.0.ebuild b/dev-python/sentinels/sentinels-1.0.0.ebuild
new file mode 100644
index 000000000000..664a217c9ed5
--- /dev/null
+++ b/dev-python/sentinels/sentinels-1.0.0.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Sentinels class which are objects with special meanings."
+HOMEPAGE="https://pypi.org/project/sentinels"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests nose