summaryrefslogtreecommitdiff
path: root/dev-python/serpent/serpent-1.28.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/serpent/serpent-1.28.ebuild')
-rw-r--r--dev-python/serpent/serpent-1.28.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/serpent/serpent-1.28.ebuild b/dev-python/serpent/serpent-1.28.ebuild
new file mode 100644
index 000000000000..44dc1e5ccf25
--- /dev/null
+++ b/dev-python/serpent/serpent-1.28.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple serialization library based on ast.literal_eval"
+HOMEPAGE="https://pypi.org/project/serpent/ https://github.com/irmen/Serpent"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}