summaryrefslogtreecommitdiff
path: root/dev-python/setproctitle/setproctitle-1.3.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/setproctitle/setproctitle-1.3.3.ebuild')
-rw-r--r--dev-python/setproctitle/setproctitle-1.3.3.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/setproctitle/setproctitle-1.3.3.ebuild b/dev-python/setproctitle/setproctitle-1.3.3.ebuild
new file mode 100644
index 000000000000..e21c847478f5
--- /dev/null
+++ b/dev-python/setproctitle/setproctitle-1.3.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Allow customization of the process title"
+HOMEPAGE="
+ https://github.com/dvarrazzo/py-setproctitle/
+ https://pypi.org/project/setproctitle/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+distutils_enable_tests pytest