summaryrefslogtreecommitdiff
path: root/dev-python/setuptools-scm
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/setuptools-scm')
-rw-r--r--dev-python/setuptools-scm/Manifest2
-rw-r--r--dev-python/setuptools-scm/setuptools-scm-8.2.0.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/setuptools-scm/Manifest b/dev-python/setuptools-scm/Manifest
index 0dbda004fd9b..3b3423c2e0e2 100644
--- a/dev-python/setuptools-scm/Manifest
+++ b/dev-python/setuptools-scm/Manifest
@@ -1,3 +1,5 @@
DIST setuptools_scm-8.1.0.tar.gz 76465 BLAKE2B f50a1c25c93179809cb448dbaeab9d71596c729e374c88c2f8d9f5f7a1d746a001f9aa9fb93478679f1c1af96f35313e1250f96375f56310a4b814ee0542ed52 SHA512 205f1c122539d107a61a7ef01ff9ec225f7b2e6d92fc33a9f2a0c616051cbf32163ac4e6878d898e51cc1ff81fce6c6521a18fc5e09bdbc9d7d2467ba013c57f
+DIST setuptools_scm-8.2.0.tar.gz 77572 BLAKE2B 105ddebf318a1bc0d1f0ee0e5232f5af8a43a8ed0908bd6ffceb6ba188ff8640b681a0a98006f67cc8c2f82917e6e0565f8a1aba44e8d7ff29700e3d158dde22 SHA512 3f4c4eb8a3e4f71a29187486cdc00b1e9af9b577c55a58b5ad03e6c6bad50b638b2e23ed8ee3db739481f8380d126635b42213b16172e79ba9f6ec81ce774e27
EBUILD setuptools-scm-8.1.0.ebuild 1528 BLAKE2B 9d07d2228b1e9202931c090b59eb2a9457ee27eef3896980977496077e2e92e8d827fe0910d57dc060d58da8650ac1fbbdccada1b246a456b160c5adb6661f64 SHA512 e51de78db445a28158a4ab09d76f26b3a21a369fb84e9e90e294dd71885aa7204178c65117527ede7d8aad15adb945292e70afb3cb0a2c3b009ff54e61f21ccb
+EBUILD setuptools-scm-8.2.0.ebuild 1549 BLAKE2B 76ab437441ec22caaa1f6695c0f30cb67aa9f0a4c50d9b5ff4660495be4af2e8814cb1c118e04fac83eb5253a9cde9c7b4f6dd71bcee253d95fb275da543e9ac SHA512 16163d119e3ef10d125069b24b009deba5b3ef1581dbdaeb208ba805ba2ae8cfb7901dcd077fba5868d486c16456181bf0ea4128a7a4d3fd5f77c689646fbb26
MISC metadata.xml 401 BLAKE2B 21b30ecc3681b1c9739fd259be0930bb2b9334babdeb3c6eefdd57a08dfba2671ccb7f5bf4aa01e9b6d87920a1fe33bc33b2265feaadc566acf6f1d84f1e78ac SHA512 c106b86da6e1936c44e313c1ce9dd07bf8ee94fd869759a485242bf7ad60628771aad9d981ffd0f8658729c83441d4edf30d54975cd5ba568ecdf6f7e79e0d83
diff --git a/dev-python/setuptools-scm/setuptools-scm-8.2.0.ebuild b/dev-python/setuptools-scm/setuptools-scm-8.2.0.ebuild
new file mode 100644
index 000000000000..b3466e7f8a31
--- /dev/null
+++ b/dev-python/setuptools-scm/setuptools-scm-8.2.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{10..13} python3_13t pypy3 pypy3_11 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Manage versions by scm tags via setuptools"
+HOMEPAGE="
+ https://github.com/pypa/setuptools-scm/
+ https://pypi.org/project/setuptools-scm/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+# there's an optional dep on rich for cute logs
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-61[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-2.0.2[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/build[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # the usual nondescript gpg-agent failure
+ testing/test_git.py::test_git_getdate_signed_commit
+
+ # fetching from the Internet
+ testing/test_regressions.py::test_pip_download
+
+ # calls flake8, unpredictable
+ testing/test_functions.py::test_dump_version_flake8
+ )
+
+ if has_version dev-python/nose; then
+ EPYTEST_DESELECT+=(
+ # https://bugs.gentoo.org/892639
+ testing/test_integration.py::test_pyproject_support
+ )
+ fi
+
+ epytest
+}