summaryrefslogtreecommitdiff
path: root/dev-python/shiboken6
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/shiboken6')
-rw-r--r--dev-python/shiboken6/Manifest4
-rw-r--r--dev-python/shiboken6/shiboken6-6.7.2.ebuild (renamed from dev-python/shiboken6/shiboken6-6.7.0.ebuild)14
2 files changed, 7 insertions, 11 deletions
diff --git a/dev-python/shiboken6/Manifest b/dev-python/shiboken6/Manifest
index 2396ede0eaf1..9ffefe6d3c5d 100644
--- a/dev-python/shiboken6/Manifest
+++ b/dev-python/shiboken6/Manifest
@@ -1,4 +1,4 @@
AUX shiboken6-6.3.1-no-strip.patch 1001 BLAKE2B c486f9423d4934c2305e8f3109f017dbebd568573469a2fced8da895fbc61ef07a80e0d1c846e7a57988801d6ec4be05b86b46a8039e6702d667129a899fc137 SHA512 1f3e5b082a978e3ab8d8f4d9a5a0a661b8c063e2ece0221440abe342fbd45d566a384d588dbf00a1e469687f82da3728cd53e35d02077ce6a748d3747de3cec2
-DIST pyside-setup-everywhere-src-6.7.0.tar.xz 14382456 BLAKE2B 607e496cdeb7e55166b4f0dc15662a8792c7d8925856e8edbb927dfdc33342d158f430e3433d3d4a78ea33740e333fb2422ea1f4332408c3c6214f92d31bdd0d SHA512 7801d564d8d359edec431dc0e6f170538b9fc6f834cb7ab8eff41c1989bffb619c446d4d62d65db2a5b7592c0bff5d450d42de2797726658fe1a8f53df8a4c14
-EBUILD shiboken6-6.7.0.ebuild 6643 BLAKE2B 38ff1bb399b524cf002d286d3fce0ddb46d2693a6e06f3dbafcbb66d21076377c322d3d94de9a1ee9cfc301794c51c8336bc1b76bf10d2ceef1f9e4e2e0d2bf1 SHA512 ef1786d3cce0288384f3aa0a10d76d514b7952f5ff63a5ce2fe0df5ba7a1613fe6401445ed90be3b170c4287540570da1e798ca43fc9a66eafb9cb2a9377a96b
+DIST pyside-setup-everywhere-src-6.7.2.tar.xz 14402156 BLAKE2B 321717ba46c7ed29404ee326f852cd4032f93e23b6b32a16e4e05305ff04a00a2029ee7c1d50ad7191a836ffd9a3ae858483bac35e8254bdcaeb474e2c92df60 SHA512 4376aba85867b5a04dab9d8889f5e32cb503cb8010757c1e810e60d29755f15a002b582594d0737a4119c030b48ede26964e8b1392700a6c061d7d631cdfe73e
+EBUILD shiboken6-6.7.2.ebuild 6582 BLAKE2B d1a943152f6fc8a2df1b14b407654f7e1ca6ae1a8a6e5dd770ec4c7d3d6ad4b8c709f485fcfa3c3a3b9c5781b69fe996e9319bf2c0ca18ff7b68a2f897cda6b2 SHA512 d846ca529ebf5aab279489b447a101e80fb3d9793f136eaf8ec4a2647751dd90148505930c8234576f1fd5d6b29b07d83f1b6db841d9220499ac4c09bf8c3658
MISC metadata.xml 730 BLAKE2B 33e7e589d02ec0517e134aa50407ecb97c6800be3ab7b69174d65776f62c1f25c2b2209d51299d9e0110b5f5e9322ee2c0b43dc89e6b12c40ea322ca9bc8eb3f SHA512 cc4ecdd9bc86ce59c2027c6f87307d32bd76d5d2cd8c07edb6c60cc5317ea52a96136c7597a179d75f1632db2999300d8b8f0567679ba3fc562804774fcdcc98
diff --git a/dev-python/shiboken6/shiboken6-6.7.0.ebuild b/dev-python/shiboken6/shiboken6-6.7.2.ebuild
index faac009c177a..aa0074264df0 100644
--- a/dev-python/shiboken6/shiboken6-6.7.0.ebuild
+++ b/dev-python/shiboken6/shiboken6-6.7.2.ebuild
@@ -12,11 +12,11 @@ EAPI=8
# "/usr/bin/shiboken6" at build time and "libshiboken6-*.so" at runtime.
# TODO: Add PyPy once officially supported. See also:
# https://bugreports.qt.io/browse/PYSIDE-535
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
LLVM_COMPAT=( {15..18} )
-inherit cmake flag-o-matic llvm-r1 python-r1 toolchain-funcs
+inherit cmake llvm-r1 python-r1 toolchain-funcs
MY_PN="pyside-setup-everywhere-src"
@@ -30,8 +30,8 @@ S="${WORKDIR}/${MY_PN}-${PV}/sources/shiboken6"
# with version 1.0 of a Qt-specific exception enabling shiboken6 output to be
# arbitrarily relicensed. (TODO)
LICENSE="|| ( GPL-2 GPL-3+ LGPL-3 ) GPL-3"
-SLOT="0"
-KEYWORDS="amd64"
+SLOT="6/${PV}"
+KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv ~x86"
IUSE="+docstrings numpy test vulkan"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
@@ -54,6 +54,7 @@ RDEPEND="${PYTHON_DEPS}
)
numpy? ( dev-python/numpy[${PYTHON_USEDEP}] )
vulkan? ( dev-util/vulkan-headers )
+ !dev-python/shiboken6:0
"
DEPEND="${RDEPEND}
test? ( =dev-qt/qtbase-${QT_PV}[gui] )
@@ -109,11 +110,6 @@ src_prepare() {
}
src_configure() {
- # -Werror=odr
- # https://bugs.gentoo.org/925479
- # https://bugreports.qt.io/browse/PYSIDE-2619
- filter-lto
-
# Minimal tests for now, 2 failing with the extended version
# FIXME Subscripted generics cannot be used with class and instance checks
local mycmakeargs=(