summaryrefslogtreecommitdiff
path: root/dev-python/simplegeneric/simplegeneric-0.8.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/simplegeneric/simplegeneric-0.8.1-r1.ebuild')
-rw-r--r--dev-python/simplegeneric/simplegeneric-0.8.1-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/simplegeneric/simplegeneric-0.8.1-r1.ebuild b/dev-python/simplegeneric/simplegeneric-0.8.1-r1.ebuild
new file mode 100644
index 000000000000..3f5962302f11
--- /dev/null
+++ b/dev-python/simplegeneric/simplegeneric-0.8.1-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple generic functions for Python"
+HOMEPAGE="https://pypi.python.org/pypi/simplegeneric"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+DEPEND="
+ app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+python_test() {
+ esetup.py test
+}