summaryrefslogtreecommitdiff
path: root/dev-python/simplejson/simplejson-3.19.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/simplejson/simplejson-3.19.1.ebuild')
-rw-r--r--dev-python/simplejson/simplejson-3.19.1.ebuild2
1 files changed, 2 insertions, 0 deletions
diff --git a/dev-python/simplejson/simplejson-3.19.1.ebuild b/dev-python/simplejson/simplejson-3.19.1.ebuild
index 3d2130d9f7c4..a014c1d7ed9b 100644
--- a/dev-python/simplejson/simplejson-3.19.1.ebuild
+++ b/dev-python/simplejson/simplejson-3.19.1.ebuild
@@ -25,6 +25,8 @@ DOCS=( README.rst CHANGES.txt )
distutils_enable_tests unittest
src_configure() {
+ # native-extensions are always disabled on PyPy
+ # https://github.com/simplejson/simplejson/blob/master/setup.py#L121
export DISABLE_SPEEDUPS=$(usex native-extensions 0 1)
use native-extensions && export REQUIRE_SPEEDUPS=1
}