summaryrefslogtreecommitdiff
path: root/dev-python/simsimd
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/simsimd')
-rw-r--r--dev-python/simsimd/Manifest2
-rw-r--r--dev-python/simsimd/simsimd-5.0.1.ebuild64
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/simsimd/Manifest b/dev-python/simsimd/Manifest
index 5edcada10eb3..333ec4a62c59 100644
--- a/dev-python/simsimd/Manifest
+++ b/dev-python/simsimd/Manifest
@@ -1,5 +1,7 @@
DIST SimSIMD-4.3.1.gh.tar.gz 105424 BLAKE2B b5886261ad8290662325321816cf9e7eeb7059b58e3e2352f341345667393d4ee009a840061768666234ae2619bbd4c7522726a2efc4f60935309a393649fd22 SHA512 722a8ae473d4526130a0d80bd6074ba6cee7a2566414505b7db8cd4d63efade2470153e4364a9cff140780fc839264c7ccb6580983170d25ff3bbb4a00d78155
DIST SimSIMD-5.0.0.gh.tar.gz 120734 BLAKE2B 40a51018334e81ada820f394a2bc1f7560b00a339c4b43a23e071a492129375af2d7155205ad3b1b0f6915579a49f10ed839b132f9f2297991a776e3f7643932 SHA512 25125d213eb773e453aafb0e2332a9a2a0798c16c01c954a5f84354c5f20a9cd9b512fda37c4cceffdbae1c2cdb9571ffbdf32ea3f0cfa6f60192f0a3d3e5c7e
+DIST SimSIMD-5.0.1.gh.tar.gz 120754 BLAKE2B 35094cf15aad8f2325706a604eb7036e3edc18828c2341d9921b76077d7d7de9028177277ea32a144fa7edd98ee2b83d83506e632f95889c2290102c9638df9e SHA512 0dde560764e4d267e7b3387e8c7e24a44da02362f651b9ea48d44f91908135d107080c8b7db2fb3578f5ebfa67082694eb2907d82ceef841271f0debf42f1a8a
EBUILD simsimd-4.3.1.ebuild 1299 BLAKE2B 2e6568e07679ca91a5b0c756b16113acb8575150a0b258cb53288851c178d099c7f5c2e59c49591f843f5decc439a1b5e8089adbf6088c855e9b492d414341f8 SHA512 0ff7c9d90362b3764ba3968c57cd633c218054899c0119ceb732754304f763fc10f72f438968b9b1c6fce1e8099fea14d154047da3698a5fa247f94a0540c720
EBUILD simsimd-5.0.0.ebuild 1299 BLAKE2B 2e6568e07679ca91a5b0c756b16113acb8575150a0b258cb53288851c178d099c7f5c2e59c49591f843f5decc439a1b5e8089adbf6088c855e9b492d414341f8 SHA512 0ff7c9d90362b3764ba3968c57cd633c218054899c0119ceb732754304f763fc10f72f438968b9b1c6fce1e8099fea14d154047da3698a5fa247f94a0540c720
+EBUILD simsimd-5.0.1.ebuild 1299 BLAKE2B 2e6568e07679ca91a5b0c756b16113acb8575150a0b258cb53288851c178d099c7f5c2e59c49591f843f5decc439a1b5e8089adbf6088c855e9b492d414341f8 SHA512 0ff7c9d90362b3764ba3968c57cd633c218054899c0119ceb732754304f763fc10f72f438968b9b1c6fce1e8099fea14d154047da3698a5fa247f94a0540c720
MISC metadata.xml 349 BLAKE2B 363881beeefbf65de7e0ab30fe5da642deefc0bbe2aeef0b4c3395a3c570f1043cb3d5e08927536a48597a44d447ff4853a5b15fffa65bbea5533377b0d6e413 SHA512 75756bd2cfb9adbdc59a2f4e3ed29c7d5daf53f427da661a9dbe6b3746ccb8ca031f650a7e505ef817b13c231cb725ca1e6eeb490be39b29e2883ca7d52f0368
diff --git a/dev-python/simsimd/simsimd-5.0.1.ebuild b/dev-python/simsimd/simsimd-5.0.1.ebuild
new file mode 100644
index 000000000000..ede8569c67d3
--- /dev/null
+++ b/dev-python/simsimd/simsimd-5.0.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 toolchain-funcs
+
+MY_P=SimSIMD-${PV}
+DESCRIPTION="Fastest SIMD-Accelerated Vector Similarity Functions for x86 and Arm"
+HOMEPAGE="
+ https://github.com/ashvardanian/SimSIMD/
+ https://pypi.org/project/simsimd/
+"
+# no sdist, as of 4.3.1
+# https://github.com/ashvardanian/SimSIMD/issues/113
+SRC_URI="
+ https://github.com/ashvardanian/SimSIMD/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="openmp"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-repeat[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]] && use openmp; then
+ tc-check-openmp
+ fi
+}
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]] && use openmp; then
+ tc-check-openmp
+ fi
+}
+
+src_prepare() {
+ # https://github.com/ashvardanian/SimSIMD/pull/115
+ sed -i -e '/-O3/d' -e 's:-lgomp:-fopenmp:' setup.py || die
+ if ! use openmp; then
+ sed -i -e '/-fopenmp/d' setup.py || die
+ fi
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p repeat python/test.py
+}