summaryrefslogtreecommitdiff
path: root/dev-python/sip
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sip')
-rw-r--r--dev-python/sip/Manifest2
-rw-r--r--dev-python/sip/sip-6.10.0.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/sip/Manifest b/dev-python/sip/Manifest
index b399eadfeef6..b61c9eaf49c1 100644
--- a/dev-python/sip/Manifest
+++ b/dev-python/sip/Manifest
@@ -1,3 +1,5 @@
+DIST sip-6.10.0.gh.tar.gz 2448793 BLAKE2B bbd88954884c83d489e86b6ffc0098dc0d5266bd06e31e4289464a0455d489fa260373e730ede45873834df8bc09b7ab7a6c411c8b82971aa4f3c9640849941b SHA512 b30a70c7cd62708f552b542e86449e35ae0b79f41ed2420c6c275fb5ccba605590bb3ee511e67c52c657361df0406ad0787f3bbb1c0c79d62f25bf916a0a0cee
DIST sip-6.9.1.gh.tar.gz 517896 BLAKE2B 1ed8eb2e3cdf4eca76aed82bafbfb6ed60163cc58aff7a709cff29c2b370c68d5dcfce8db04768b9133fba58a24734bbc32b7c5a004ab84a73661db690976228 SHA512 670b1afcf7c6337f48d53cea86c535f24932393d68ee1654c754bfa3481f2f736f1dc935f39f501650e210112034b0fdb8c8ec46627066d9af3be0c599e8a093
+EBUILD sip-6.10.0.ebuild 855 BLAKE2B 12fb1beb0b03b9d70abe876101a1433f946f22d3aadc11f29a653c9c5922da84df9c8756c080c28467221df3ce7bcdf029e4f94b70507bd66ea998f130e17a63 SHA512 49f6e802279c0e116670b0154687ce2ceded2577b08a5c479cfe40edf406f88ee97985a2b5ab4360f6bf5d43dd1930fd77aafa5029617ee2a5dd13eb2e6f78d0
EBUILD sip-6.9.1.ebuild 849 BLAKE2B 985e254c4f7e7810541b7d792f378c855ce4433418e4f874eaabce3116f865cff5dcd6f2c2a40b58753aa11c8723004391a39dc85ded39f70e70bd7abf42429d SHA512 b6b2d4dc861857525a41029841fe15ef43c6097e5710ea5cfe411ead400d286a34af3053f1758b0790542f8d88a494ba304f3c716086dfe0552d182b978b4f1e
MISC metadata.xml 524 BLAKE2B 57657d01dc5be425f66f1136356fa028a32ad6a2ca79cadf4b9ed6a940b414b0e3efa161895d1858ab3d4977241883f9dfefbe37a8cbaad10589d57f598856a1 SHA512 82208b61b297d8c2110ea47a82c046118afd9332c52fa6590f7ed11b4e70af8b75f087b006fa5ed9058dbd2f98f02104559e085f781f2fc887396b7ff9d1b859
diff --git a/dev-python/sip/sip-6.10.0.ebuild b/dev-python/sip/sip-6.10.0.ebuild
new file mode 100644
index 000000000000..b92e6e558699
--- /dev/null
+++ b/dev-python/sip/sip-6.10.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings generator for C/C++ libraries"
+HOMEPAGE="https://github.com/Python-SIP/sip/"
+SRC_URI="
+ https://github.com/Python-SIP/sip/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD-2 BSD"
+SLOT="5"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/tomli[${PYTHON_USEDEP}]' 3.10)
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-8[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ dev-python/myst-parser \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest