summaryrefslogtreecommitdiff
path: root/dev-python/six/six-1.15.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/six/six-1.15.0-r1.ebuild')
-rw-r--r--dev-python/six/six-1.15.0-r1.ebuild28
1 files changed, 0 insertions, 28 deletions
diff --git a/dev-python/six/six-1.15.0-r1.ebuild b/dev-python/six/six-1.15.0-r1.ebuild
deleted file mode 100644
index 830bec098c8c..000000000000
--- a/dev-python/six/six-1.15.0-r1.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..10} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python 2 and 3 compatibility library"
-HOMEPAGE="https://github.com/benjaminp/six https://pypi.org/project/six/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-
-distutils_enable_sphinx documentation --no-autodoc
-distutils_enable_tests pytest
-
-python_test() {
- local deselect=()
- [[ ${EPYTHON} == pypy3 ]] && deselect+=(
- 'test_six.py::test_move_items[dbm_ndbm]'
- )
-
- epytest ${deselect[@]/#/--deselect }
-}