summaryrefslogtreecommitdiff
path: root/dev-python/snakeoil/snakeoil-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/snakeoil/snakeoil-9999.ebuild')
-rw-r--r--dev-python/snakeoil/snakeoil-9999.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-python/snakeoil/snakeoil-9999.ebuild b/dev-python/snakeoil/snakeoil-9999.ebuild
index 66ebcf075394..428f2e82cc86 100644
--- a/dev-python/snakeoil/snakeoil-9999.ebuild
+++ b/dev-python/snakeoil/snakeoil-9999.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
@@ -22,9 +23,8 @@ LICENSE="BSD BSD-2 MIT"
SLOT="0"
RDEPEND="
- dev-python/lazy-object-proxy[${PYTHON_USEDEP}]"
-BDEPEND="
- test? ( >=dev-python/pytest-6 )"
+ dev-python/lazy-object-proxy[${PYTHON_USEDEP}]
+"
[[ ${PV} == 9999 ]] && BDEPEND+=" dev-python/cython[${PYTHON_USEDEP}]"