summaryrefslogtreecommitdiff
path: root/dev-python/sniffio/sniffio-1.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sniffio/sniffio-1.2.0.ebuild')
-rw-r--r--dev-python/sniffio/sniffio-1.2.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/sniffio/sniffio-1.2.0.ebuild b/dev-python/sniffio/sniffio-1.2.0.ebuild
new file mode 100644
index 000000000000..89f3dc32585e
--- /dev/null
+++ b/dev-python/sniffio/sniffio-1.2.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Sniff out which async library your code is running under"
+HOMEPAGE="
+ https://github.com/python-trio/sniffio/
+ https://pypi.org/project/sniffio/"
+SRC_URI="
+ https://github.com/python-trio/sniffio/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="|| ( Apache-2.0 MIT )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # curio is not packaged
+ sniffio/_tests/test_sniffio.py::test_curio
+ )
+
+ pytest -vv ${deselect[@]/#/--deselect } ||
+ die "Tests failed with ${EPYTHON}"
+}