summaryrefslogtreecommitdiff
path: root/dev-python/socketio-client
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/socketio-client')
-rw-r--r--dev-python/socketio-client/Manifest3
-rw-r--r--dev-python/socketio-client/metadata.xml15
-rw-r--r--dev-python/socketio-client/socketio-client-0.7.2.ebuild50
3 files changed, 0 insertions, 68 deletions
diff --git a/dev-python/socketio-client/Manifest b/dev-python/socketio-client/Manifest
deleted file mode 100644
index 873a5ba24e74..000000000000
--- a/dev-python/socketio-client/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST socketio-client-0.7.2.tar.gz 23488 BLAKE2B 8c638dcc8ed30fb01a31e36f8175ef7e6b77b37dac0a66f1ef663a372458ccb34bac2ed58fce31a3856eb3d067ad8dc20f7d4a332b2af10ae12717bbb786349f SHA512 850839f804953c706458467c9e35c4c3637d3a61ff55042ef0b6f98e39a277faa97a0a3d7b1e18210e68ec32bb4ca793cd404631e0e2b533e61ad5d05cbc18fa
-EBUILD socketio-client-0.7.2.ebuild 1708 BLAKE2B 28b0e90a948717f3cafe83675f75079f87e1f9733a0e0f716b461d2b906bfe765ac0e8b40a45e35b4e362c39628dcebf4efb3a1283f70f6fd96d11bae35a3272 SHA512 79ea2af7758b49f2edd18b58edba99aec2314c88ce420d5e54922f25eca98dc80c79485c27688fa5e6047eb7039abe1c99a9e7bc9f8e8308e340c6c1a43ccba4
-MISC metadata.xml 467 BLAKE2B 2b0a2483db2f4fdd351061d1131649ed92d345940dab6967de8ce51809a932e824595fc852abf3240a988e566ce5385cb232a1c2cb9c8e6c466f55d5b3f5e508 SHA512 f1997eeddba6cfa54edc7941e75e809b88c5f5f2e34ff739877d9f971118f1fd1cdf940176b8a4dcec4e4381e1fd127304f854dfb16a108893a0bed610de859a
diff --git a/dev-python/socketio-client/metadata.xml b/dev-python/socketio-client/metadata.xml
deleted file mode 100644
index 61b88ed00a2a..000000000000
--- a/dev-python/socketio-client/metadata.xml
+++ /dev/null
@@ -1,15 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <upstream>
- <remote-id type="pypi">socketIO-client</remote-id>
- <remote-id type="github">invisibleroads/socketIO-client</remote-id>
- </upstream>
- <maintainer type="person">
- <email>zmedico@gentoo.org</email>
- </maintainer>
-<maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
-</pkgmetadata>
diff --git a/dev-python/socketio-client/socketio-client-0.7.2.ebuild b/dev-python/socketio-client/socketio-client-0.7.2.ebuild
deleted file mode 100644
index 849bbbdc744f..000000000000
--- a/dev-python/socketio-client/socketio-client-0.7.2.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{9..10} )
-
-inherit distutils-r1
-
-MY_PN="socketIO-client"
-DESCRIPTION="A socket.io client library for Python"
-HOMEPAGE="https://github.com/invisibleroads/socketIO-client/ https://pypi.org/project/socketIO-client/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]
- >=dev-python/requests-2.7.0[${PYTHON_USEDEP}]
- dev-python/websocket-client[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- )"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-python_test() {
- # https://github.com/invisibleroads/socketIO-client/issues/90
- # This runs the suite but has nill output to the screen
- # The bug filed will hopefully yield a more conventional testsuite
-
- # The import of SocketIO need be made with abs path to run the tests
- sed -e 's:from .. import:from socketIO_client import:' \
- -i socketIO_client/tests/__init__.py || die
- sed -e 's:from ..exceptions import:from socketIO_client.exceptions import:' \
- -i socketIO_client/tests/__init__.py || die
-
- "${PYTHON}" socketIO_client/tests/__init__.py || \
- die "Tests failed under ${EPYTHON}"
-
- # Return to original form for final install
- sed -e 's:from socketIO_client import:from .. import:' \
- -i socketIO_client/tests/__init__.py || die
- sed -e 's:from socketIO_client.exceptions import:from ..exceptions import:' \
- -i socketIO_client/tests/__init__.py || die
-}