summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-autoapi
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sphinx-autoapi')
-rw-r--r--dev-python/sphinx-autoapi/Manifest2
-rw-r--r--dev-python/sphinx-autoapi/sphinx-autoapi-3.1.2.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/sphinx-autoapi/Manifest b/dev-python/sphinx-autoapi/Manifest
index 02ff0da03619..e6189f8cee42 100644
--- a/dev-python/sphinx-autoapi/Manifest
+++ b/dev-python/sphinx-autoapi/Manifest
@@ -1,3 +1,5 @@
DIST sphinx-autoapi-3.1.1.gh.tar.gz 67903 BLAKE2B aec809e53b2c1080a29c49f5d9916df2e9def0c2072d99dde7ee3250a9cc7a9fc2d1e3e76ad954cfc417205c9b8994dcb7d0533f5994eb2a584d8ffa3ee3260e SHA512 c5a3db4f6e3969af8f8f2933822e577d3469c649f6976327e55c449cd6992274ee896a7ad01d5a3bfab378819bd4fe319b9f08e989214c00b4844c03c56ed2c8
+DIST sphinx-autoapi-3.1.2.gh.tar.gz 68260 BLAKE2B 31315fb298f7dae78c10f839e2738340eaf68d5497f22368c50f14309a564d1c5636015a715a9f99080a4f753416a10c63147e63dfcd53a27d7466ad422f95c4 SHA512 18e4a49e831446fa14278ffda4fec703f3b2c86654ce78fa7f4b89e5a41f1e6b19ea76cb64e7290a3125dc027a2de8aa052495a8bfd4bcc1828780f762e81957
EBUILD sphinx-autoapi-3.1.1.ebuild 1200 BLAKE2B 4bbba3f93c9551951cdefb3021bf30c14d6ab17a83f6583bc958b77d6fef867ba326eb0ce064377d335a202b0a11e56019a4a2b5416d717af1009aaa02b71143 SHA512 cef1a5d729d47b94d56f535acb9bd15f0f3c6aa85dce335b10cd99c00e94bd85cede9caeb0e67aeff1283a4485de3a689af03c614cc6ebd7201e48ad85c78383
+EBUILD sphinx-autoapi-3.1.2.ebuild 1204 BLAKE2B a579b2d50c84d93a517f4ce46d56f0989d5332e03adefcacae1d66d9c17ef641c9e8429d926529550e35bc5083defc8871eb3840295bb7cbb5b0a2e5b52f6993 SHA512 87782e5a48582dacdba1a6b1aff2559201db0f4943a5cbf1402f91c4889003fee713f622182a65bf088d14ccc8d3b02d25a49c8cd30b1b893dd30aeffc715a9b
MISC metadata.xml 769 BLAKE2B 6f85e487a2d2def289bb54a6addc2338bb8af85b323ec1c95851945f9c407ec22bfadd8079ac8b6e00cfbc85caa0e2b09d82329f1f87a365fc44b69c7bcd9a20 SHA512 68f02a5f98234c2a5cb15aa04ce90077b154a7e3a7a69dc0a1d0a6b5c7b42c60624878a7e2fff1576c8b586fc15e7ef042942274d4e8473835bb3d8bfdbd8393
diff --git a/dev-python/sphinx-autoapi/sphinx-autoapi-3.1.2.ebuild b/dev-python/sphinx-autoapi/sphinx-autoapi-3.1.2.ebuild
new file mode 100644
index 000000000000..9182b8aa4e2c
--- /dev/null
+++ b/dev-python/sphinx-autoapi/sphinx-autoapi-3.1.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A new approach to API documentation in Sphinx"
+HOMEPAGE="
+ https://sphinx-autoapi.readthedocs.io/
+ https://github.com/readthedocs/sphinx-autoapi/
+ https://pypi.org/project/sphinx-autoapi/
+"
+# sdist is missing docs, as of 2.1.0
+SRC_URI="
+ https://github.com/readthedocs/sphinx-autoapi/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/astroid-3.0.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-6.1.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND+="
+ test? ( dev-python/beautifulsoup4[${PYTHON_USEDEP}] )
+"
+
+DOCS=( README.rst CHANGELOG.rst )
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Internet
+ tests/python/test_pyintegration.py::TestPEP695::test_integration
+ tests/python/test_pyintegration.py::TestPipeUnionModule::test_integration
+ "tests/test_integration.py::TestExtensionErrors::test_extension_setup_errors[dotnetexample"
+ )
+
+ distutils-r1_python_test
+}