summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.14.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.14.0.ebuild')
-rw-r--r--dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.14.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.14.0.ebuild b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.14.0.ebuild
new file mode 100644
index 000000000000..2791bdf02bb4
--- /dev/null
+++ b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.14.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Type hints support for the Sphinx autodoc extension "
+HOMEPAGE="
+ https://github.com/tox-dev/sphinx-autodoc-typehints/
+ https://pypi.org/project/sphinx-autodoc-typehints/
+"
+SRC_URI="
+ https://github.com/tox-dev/sphinx-autodoc-typehints/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+SLOT="0"
+
+RDEPEND=">=dev-python/sphinx-4[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/sphobjinv[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # this package is addicted to Internet
+ tests/test_sphinx_autodoc_typehints.py::test_format_annotation
+)
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}