summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-applehelp/sphinxcontrib-applehelp-1.0.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sphinxcontrib-applehelp/sphinxcontrib-applehelp-1.0.3.ebuild')
-rw-r--r--dev-python/sphinxcontrib-applehelp/sphinxcontrib-applehelp-1.0.3.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/sphinxcontrib-applehelp/sphinxcontrib-applehelp-1.0.3.ebuild b/dev-python/sphinxcontrib-applehelp/sphinxcontrib-applehelp-1.0.3.ebuild
deleted file mode 100644
index 2c01d739d7c0..000000000000
--- a/dev-python/sphinxcontrib-applehelp/sphinxcontrib-applehelp-1.0.3.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Sphinx extension which outputs Apple help book"
-HOMEPAGE="
- https://www.sphinx-doc.org/
- https://github.com/sphinx-doc/sphinxcontrib-applehelp/
- https://pypi.org/project/sphinxcontrib.applehelp/
-"
-SRC_URI="
- https://github.com/sphinx-doc/sphinxcontrib-applehelp/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-
-PDEPEND="
- >=dev-python/sphinx-2.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? ( ${PDEPEND} )
-"
-
-distutils_enable_tests pytest
-
-python_compile() {
- distutils-r1_python_compile
- find "${BUILD_DIR}" -name '*.pth' -delete || die
-}
-
-python_test() {
- distutils_write_namespace sphinxcontrib
- cd "${T}" || die
- epytest "${S}"/tests
-}