summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-httpdomain
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sphinxcontrib-httpdomain')
-rw-r--r--dev-python/sphinxcontrib-httpdomain/Manifest2
-rw-r--r--dev-python/sphinxcontrib-httpdomain/sphinxcontrib-httpdomain-1.7.0.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-httpdomain/Manifest b/dev-python/sphinxcontrib-httpdomain/Manifest
index 97be3fa22454..ed45fd38e424 100644
--- a/dev-python/sphinxcontrib-httpdomain/Manifest
+++ b/dev-python/sphinxcontrib-httpdomain/Manifest
@@ -1,3 +1,5 @@
DIST sphinxcontrib-httpdomain-1.5.0.tar.gz 13981 BLAKE2B ca08a5cdc22d9898c6972ce8b7585fc4f185e3a0c8e49302bfafbfc88b4bb69d9d3deaf15cca2dfcd2f218199f509023aeb542129fea2003cecb2e8ef8215fd4 SHA512 e393690314cb7a7b81207ee42826eb5360ca6cfa8ad1b57c9a8dd5897ed1ed97bad4a46d8348aad9d5f6b6145e5456af629b14973ad2561d5b90b2f8dbf2163a
+DIST sphinxcontrib-httpdomain-1.7.0.tar.gz 37493 BLAKE2B e34682029ed2f59cb8c70b2a5270a2f89c4cb08179fdf3a53c65f1ad23eebba71bff5385b5d3fd971a6e3341457b253e4187632a8bf856ca208843938bbde056 SHA512 8c6e40dfaa29a552164078fbc96de578b2aac269cb0ce5e228293a85f87c4db4ef8c902868caccaca709df938d4e3917cc77b3da9bd889b9c6f8c6fa242dcc0d
EBUILD sphinxcontrib-httpdomain-1.5.0.ebuild 800 BLAKE2B eef5af929417398dad90c696df9bdfe95dbbf1daa9e751db894af5310a27f6b5b4de7eaa54aa5a41256da940ec37149b9e705e1c9060556e2eb71d8d5b8171a2 SHA512 732195d97558f0a8b2ad135f051214c99a46d675bb74a6262cee3ad011743f5658e7a2915f3f187459a98cf069979ba8572ef99edfefa8e00287d17e4e24ed75
+EBUILD sphinxcontrib-httpdomain-1.7.0.ebuild 863 BLAKE2B 397b03758a9698a27ba60a4210b6b8c6bd597444516295132687dd01dc05c9921c15d9cedfabcf0fdfe0334eb5e43bdecd89fe62c311d838c6d74e5b3bda309c SHA512 e58310c3110c80c9dd18eb31e09e17140412c9b0744d6c1b5059644cb5d8069c1267f85c90df8bafcd4af02ccb92ab42fb67240806f18628dd249194d80bce6c
MISC metadata.xml 407 BLAKE2B cf0e92bcd492b79892ebc97b7639c016b4d1853a87bed8fcd1e367a9f6cbadce01015895d22011425aba76a4895b245bee0e5536fc959224a6bed08daef74a88 SHA512 155696e449933084fbe56dd900e15d17e12d52d6af29eb4fcb6c05ddfe8c6fa716974fa27085c34ae2e1af0d1739dba2616eb12092c606b2645f2008e51d64a3
diff --git a/dev-python/sphinxcontrib-httpdomain/sphinxcontrib-httpdomain-1.7.0.ebuild b/dev-python/sphinxcontrib-httpdomain/sphinxcontrib-httpdomain-1.7.0.ebuild
new file mode 100644
index 000000000000..129a707fd966
--- /dev/null
+++ b/dev-python/sphinxcontrib-httpdomain/sphinxcontrib-httpdomain-1.7.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Extension providing a Sphinx domain for describing RESTful HTTP APIs"
+HOMEPAGE="https://github.com/sphinx-contrib/httpdomain
+ https://sphinxcontrib-httpdomain.readthedocs.io/"
+SRC_URI="https://github.com/sphinx-contrib/httpdomain/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN#sphinxcontrib-}-${PV}"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}