summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-jsmath
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sphinxcontrib-jsmath')
-rw-r--r--dev-python/sphinxcontrib-jsmath/Manifest1
-rw-r--r--dev-python/sphinxcontrib-jsmath/sphinxcontrib-jsmath-1.0.1-r3.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-jsmath/Manifest b/dev-python/sphinxcontrib-jsmath/Manifest
index cc210a48a0ec..31d33e3cea92 100644
--- a/dev-python/sphinxcontrib-jsmath/Manifest
+++ b/dev-python/sphinxcontrib-jsmath/Manifest
@@ -1,3 +1,4 @@
DIST sphinxcontrib-jsmath-1.0.1.tar.gz 5787 BLAKE2B 055ff298e11678d7d30975e4bef509ece0128be30ca0c5fd2be1323c2eb4fe92f861826ea5ddfcbd2d3e3a80535b374d2b1a13446c2604f3e448d5a8982b9881 SHA512 c1e6488f5c0ca4567c27ec7c597c9db321ac32ce354c4ad62fea534b2ae1c0acb183a921f46216bbc3891f14acfaac05ddf324b8fdaf99828df07bc91aa7e5c7
EBUILD sphinxcontrib-jsmath-1.0.1-r2.ebuild 961 BLAKE2B 6f74737904141838729763a85e3da2b7e20c5549f427fe325ecacc4ea5c52b3d67cab6c9c3ff0f208007cd16c4ea9dd8319e849edbc3bd862a0a7eacdff50eb4 SHA512 397a2ec827764f3c914065a7bbc5fdc3a8d6102d64138977ef295f270d48a3290f9fc087db03b639989d9a2dc0004fb95688ea83f7f951e5651e8a239a5bce95
+EBUILD sphinxcontrib-jsmath-1.0.1-r3.ebuild 1213 BLAKE2B 7e470eb2b69c246c8765709c65c48d4b28d220cf5b6af7feef46d751f967b3c2f98e5fcdfea0a37f015068bb6cd7adb45fb21613aa394d7ff9a27f50e61bb6c5 SHA512 9cef7ad308f4c8475eb12ddcf78d1c2997e3eb2ef5006dda7e289e794cd7e6c308dc93bbca18d76061ba1c63daf735a6d653eb31d50f04f04000b0ca3d66faa2
MISC metadata.xml 419 BLAKE2B 7b22df905fbf04eb026a37a8bcf2512508558a000793354a80fd7cb06bcacbb032291c24b1edd40cf884248bb761f9e9638b5ff55c6d59aa406777dfe2361214 SHA512 3fec9aaa8e570dfb8c4559dee30b71bdc479d5ac18431fcf85d1fd415adce54b8f2783ced3a5392a08ed083570622e500bf489c7b168f65a395248aa2c235629
diff --git a/dev-python/sphinxcontrib-jsmath/sphinxcontrib-jsmath-1.0.1-r3.ebuild b/dev-python/sphinxcontrib-jsmath/sphinxcontrib-jsmath-1.0.1-r3.ebuild
new file mode 100644
index 000000000000..a153b591a758
--- /dev/null
+++ b/dev-python/sphinxcontrib-jsmath/sphinxcontrib-jsmath-1.0.1-r3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx extension which renders display math in HTML via JavaScript"
+HOMEPAGE="
+ https://www.sphinx-doc.org/
+ https://github.com/sphinx-doc/sphinxcontrib-jsmath/
+ https://pypi.org/project/sphinxcontrib-jsmath/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+PDEPEND="
+ >=dev-python/sphinx-2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? ( ${PDEPEND} )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # This is already fixed in upstream, remove it on next version bump,
+ # see https://github.com/sphinx-doc/sphinxcontrib-jsmath/pull/10
+ sed -i 's/.text()/.read_text()/' tests/test_jsmath.py || die
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ distutils_write_namespace sphinxcontrib
+ cd "${T}" || die
+ epytest "${S}"/tests
+}