summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-serializinghtml
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sphinxcontrib-serializinghtml')
-rw-r--r--dev-python/sphinxcontrib-serializinghtml/Manifest1
-rw-r--r--dev-python/sphinxcontrib-serializinghtml/sphinxcontrib-serializinghtml-2.0.0-r1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-serializinghtml/Manifest b/dev-python/sphinxcontrib-serializinghtml/Manifest
index a355f76b8530..26cbb2498ec0 100644
--- a/dev-python/sphinxcontrib-serializinghtml/Manifest
+++ b/dev-python/sphinxcontrib-serializinghtml/Manifest
@@ -1,3 +1,4 @@
DIST sphinxcontrib_serializinghtml-2.0.0.tar.gz 16080 BLAKE2B f5a3d99adbbfbb625b7a91b02dc0ebcd94dfe4ba27d778a0f74dde4c0284f5be24206f9660cd9a261f32effd9ab58c9c1ea6e4fcc6db563fd8fbd5b6fde922b5 SHA512 a71f8a25f1ab4b8cec9a2bf6a1fafbf19ee7211cb428b2cfa6d5e37c89d9ba4311e809621fcdaf3b94706d03334359d675eff16d4a6c2b32b4f20430a98544db
+EBUILD sphinxcontrib-serializinghtml-2.0.0-r1.ebuild 742 BLAKE2B d89cf1b4ad797120355e27e5fb129157e83b5815afd7d4c777f54c24abe7af41ae9086f6162759f54d7aa6b86236ef4984443e8a62a16e174ddca38ed31d1739 SHA512 c6636e43304b9dc6695acb41b93d174fcff059a171a0318bfdc1f1f036abd9b4eea331216acef372a1873286f5c2efe4da7848a4d92eead299f9f549ddcfea9e
EBUILD sphinxcontrib-serializinghtml-2.0.0.ebuild 748 BLAKE2B 19ceb5432fa0521ce3755f3ff1367279fda9ce8a6088a2e72fdccf1c985769a794ae37513615d77876e8ea8f9eb9c8d8014abba56f9d1d2aab60b9fe15898542 SHA512 260d16f84514aba91116aff53c03b6dbac225b515d9fd04fb05dcb5a5a10cec1cef5f4716f4b8aa288342072a28e838e57eb9521f4554240b8b696a050bfdda8
MISC metadata.xml 437 BLAKE2B 6b040f2d00f91a4f275afa689de0eb172fe59e4b16685f30181901e4abc6d72bd8684e2a5503a5712a22cd2eead81d1433a504568d9d596ed109afd632b8b575 SHA512 7606411699692a843b2ac349d9c60905009c02691e94c73dd6a271ea4ad9f2c1c5c972ff54f45612977374e7e850457dbd7ed63b2fe5f16b11c7fa45999b9f63
diff --git a/dev-python/sphinxcontrib-serializinghtml/sphinxcontrib-serializinghtml-2.0.0-r1.ebuild b/dev-python/sphinxcontrib-serializinghtml/sphinxcontrib-serializinghtml-2.0.0-r1.ebuild
new file mode 100644
index 000000000000..4b83aa58e2d4
--- /dev/null
+++ b/dev-python/sphinxcontrib-serializinghtml/sphinxcontrib-serializinghtml-2.0.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{11..13} pypy3_11 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx extension which outputs outputs serialized HTML files"
+HOMEPAGE="
+ https://www.sphinx-doc.org/
+ https://github.com/sphinx-doc/sphinxcontrib-serializinghtml/
+ https://pypi.org/project/sphinxcontrib-serializinghtml/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+PDEPEND="
+ >=dev-python/sphinx-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? ( ${PDEPEND} )
+"
+
+distutils_enable_tests pytest