summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-4.3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-4.3.0.ebuild')
-rw-r--r--dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-4.3.0.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-4.3.0.ebuild b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-4.3.0.ebuild
deleted file mode 100644
index f897fd1fd866..000000000000
--- a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-4.3.0.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit distutils-r1
-
-DESCRIPTION="Sphinx spelling extension"
-HOMEPAGE="https://github.com/sphinx-contrib/spelling"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-COMMON_DEPEND="
- dev-python/pbr[${PYTHON_USEDEP}]
- dev-python/pyenchant[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? (
- ${COMMON_DEPEND}
- >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
- dev-python/testtools[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="${COMMON_DEPEND}
- dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
-"
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- "${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/build/html/. )
- distutils-r1_python_install_all
- find "${ED}" -name '*.pth' -delete || die
-}