summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-spelling
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sphinxcontrib-spelling')
-rw-r--r--dev-python/sphinxcontrib-spelling/Manifest2
-rw-r--r--dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-8.0.1.ebuild54
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-spelling/Manifest b/dev-python/sphinxcontrib-spelling/Manifest
index 25023c8059f4..b79fc9ce875e 100644
--- a/dev-python/sphinxcontrib-spelling/Manifest
+++ b/dev-python/sphinxcontrib-spelling/Manifest
@@ -1,3 +1,5 @@
DIST sphinxcontrib-spelling-8.0.0.tar.gz 37610 BLAKE2B 8ae9fb62a5a7d35194884ce075b27b0e54f54c18d55f9573bc53ef7b2f953011655631e37ac3bb7c988df470c8cdf1cb576e4830c61fddc068e50d382d067751 SHA512 0d8c21ea660516238c43fabb505666dfee15abb39f538c40c6b61f91e20c246b16aa170cd444263507dd51913a27fc7719cddb28f30eab26825b565f70dd3ab6
+DIST sphinxcontrib_spelling-8.0.1.tar.gz 36005 BLAKE2B 75813ea9bc90fc87a657f16b5ca057628041dd5628a2489b259c7009662c9e0dea2c60271c2ee87336e2f0a5cd15e9e360addaad2d8e7ef36863e90ec02e5915 SHA512 8d1e98e50f040b773d117422582315f9535a8a3ccee3984012b3b21e70e8600b325f39579583cace1cd8d3eed096b187eba5e2e9b1ba0f32e5f554ac4b43d48f
EBUILD sphinxcontrib-spelling-8.0.0.ebuild 1016 BLAKE2B 37234c859bd8b164a3b67096c54d882eedf0b66d563230a40bb03812c9a75d35ac7d504d2399bfde9e238910642cc42f6ee23be5044a4c59c9cfe6c5a620fdbb SHA512 41a8aea273aa2b53d9a6d6b170fb5be4502fd72105e005b4979171e905bf4e6ffcaaf88a21186f83dd25d2b83779fc965072f2fa2500042efb668783457d8415
+EBUILD sphinxcontrib-spelling-8.0.1.ebuild 1168 BLAKE2B 06eb45a4bd78b12fb28d8201920eaef56d2c30e0e526b1d9baf651d540f78d80ca75533ed054a93521b31adbb15e7be1d9203e015e892f2f39150df967bf0041 SHA512 eec1c3c9017e7a760fa8817a8925f86d9e327bf2f7f9f49f0d3ada3604cda9b3b8d47ad7d6d2dcc71fadd736aef2870be2aa03f493d7ebbea25633e5d8239506
MISC metadata.xml 451 BLAKE2B fa659ac4949e98ca8c5a11a9b72ecba8a69ca94d95f8ab5f07c0d43d9684cd1cd21dbd63f42928a9920001904a6f75aa5663a3d924b02910c78b7894f6011722 SHA512 fead100dcd4c1d85e29260a60178e1b866ceb1f944c73fffcc051e2cfb1e96cc2e61bcf94379c0dcf84bed1349abaceb86ca9a89f2b1a8ddd384c14997d1a159
diff --git a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-8.0.1.ebuild b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-8.0.1.ebuild
new file mode 100644
index 000000000000..a140665462d7
--- /dev/null
+++ b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-8.0.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx spelling extension"
+HOMEPAGE="
+ https://github.com/sphinx-contrib/spelling/
+ https://pypi.org/project/sphinxcontrib-spelling/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/pyenchant-3.1.1[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.32.3[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-3.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ app-dicts/myspell-en
+ )
+"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires the git repo
+ tests/test_filter.py::test_contributors
+
+ # Internet
+ tests/test_filter.py::test_pypi_filter_factory
+ )
+
+ distutils_write_namespace sphinxcontrib
+ rm -rf sphinxcontrib || die
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests
+}