summaryrefslogtreecommitdiff
path: root/dev-python/spyder-unittest/spyder-unittest-0.4.1_p20220106.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/spyder-unittest/spyder-unittest-0.4.1_p20220106.ebuild')
-rw-r--r--dev-python/spyder-unittest/spyder-unittest-0.4.1_p20220106.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/spyder-unittest/spyder-unittest-0.4.1_p20220106.ebuild b/dev-python/spyder-unittest/spyder-unittest-0.4.1_p20220106.ebuild
new file mode 100644
index 000000000000..e60fa49b0a8b
--- /dev/null
+++ b/dev-python/spyder-unittest/spyder-unittest-0.4.1_p20220106.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 virtualx
+
+COMMIT="d210d9fe6c4efbb21d680a040cc4741d76a81f49"
+
+DESCRIPTION="Plugin for Spyder to run tests and view the results"
+HOMEPAGE="https://github.com/spyder-ide/spyder-unittest"
+SRC_URI="https://github.com/spyder-ide/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+# AttributeError: 'NoneType' object has no attribute 'split'
+RESTRICT="test"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/spyder-5.2.0[${PYTHON_USEDEP}]
+ dev-python/pyzmq[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+"
+
+DEPEND="test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-qt[${PYTHON_USEDEP}]
+)"
+
+distutils_enable_tests pytest
+
+python_test() {
+ virtx epytest
+}