summaryrefslogtreecommitdiff
path: root/dev-python/strict-rfc3339/strict-rfc3339-0.7-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/strict-rfc3339/strict-rfc3339-0.7-r1.ebuild')
-rw-r--r--dev-python/strict-rfc3339/strict-rfc3339-0.7-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/strict-rfc3339/strict-rfc3339-0.7-r1.ebuild b/dev-python/strict-rfc3339/strict-rfc3339-0.7-r1.ebuild
new file mode 100644
index 000000000000..07ea220922f6
--- /dev/null
+++ b/dev-python/strict-rfc3339/strict-rfc3339-0.7-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7,8}} pypy{,3} )
+
+inherit distutils-r1
+
+MY_PN="${PN}-version"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Strict, simple, lightweight RFC3339 functions"
+HOMEPAGE="https://pypi.org/project/strict-rfc3339/ https://github.com/danielrichman/strict-rfc3339"
+SRC_URI="https://github.com/danielrichman/${PN}/archive/version-${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3+"
+KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-linux ~x86-linux"
+
+S="${WORKDIR}/${MY_P}"
+
+distutils_enable_tests unittest