summaryrefslogtreecommitdiff
path: root/dev-python/subprocess-tee/subprocess-tee-0.3.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/subprocess-tee/subprocess-tee-0.3.5.ebuild')
-rw-r--r--dev-python/subprocess-tee/subprocess-tee-0.3.5.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/dev-python/subprocess-tee/subprocess-tee-0.3.5.ebuild b/dev-python/subprocess-tee/subprocess-tee-0.3.5.ebuild
index ea05ad858dc4..3c4eaee3f160 100644
--- a/dev-python/subprocess-tee/subprocess-tee-0.3.5.ebuild
+++ b/dev-python/subprocess-tee/subprocess-tee-0.3.5.ebuild
@@ -3,7 +3,9 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+
inherit distutils-r1
DESCRIPTION="subprocess.run replacement with tee(1)-like output"
@@ -24,11 +26,17 @@ BDEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]
test-full? ( app-admin/ansible-molecule )
)"
+# With the exception of a handful of extra lines this is literally the same test suite
+# as test_console.py from dev-python/enrich, which is currently known to fail (Bug #865497).
+EPYTEST_DESELECT=(
+ src/subprocess_tee/test/test_rich.py
+)
+
distutils_enable_tests pytest
python_test() {
if ! use test-full; then
- local -x EPYTEST_DESELECT=( "src/${PN/-/_}/test/test_func.py::test_molecule" )
+ EPYTEST_DESELECT+=( "src/${PN/-/_}/test/test_func.py::test_molecule" )
fi
distutils-r1_python_test
}